Support » Plugin: Jetpack by WordPress.com » Disabled XMLRPC in htaccess, but after re-enabling Jetpack can’t connect.

  • Resolved gregcrowe

    (@gregcrowe)


    Hi!

    Okay, I stupidly disabled xmlrpc.php in the .htaccess file because we were getting overwhelmed with attacks. It was a total panic move. Now that I have a good security plugin, I removed the code from .htaccess, but Jetpack can’t connect.

    I looked at xmlrpc.php in a browser and I get the expected “XML-RPC server accepts POST requests only.” I tried disabling and re-enabling Jetpack, but it still can’t connect. The Jetpack debugging tool says the is a connection error. WP’s Site Health gives an error 200 and “not Connected.

    Did I miss something in the reconnection process?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    I don’t see anything that would be blocking us outright.

    Please try deleting Jetpack specifically from the Plugins section of your blog’s Dashboard: https://jetpack.com/support/reconnecting-reinstalling-jetpack/#reinstalling-jetpack

    This will clear out Jetpack’s settings, and it should work properly after a reinstall.

    I uninstalled Jetpack and reinstalled it, and it is giving the same messages about not being connected.

    I even deleted xmlrpc.php and re-installed the latest version of WP, and still got the same result.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Would you please clarify which versions of Jetpack, WordPress, and PHP you’re running?

    Just updated to WP 5.5. Jetpack is 8.8.1. PHP I changed to 7.3 from 7.1.33 just before this started. Could that be the issue?

    I also tried to initiate a sync and it gave me this error:

    The Jetpack site is inaccessible or returned an error: server error. requested method jetpack.jsonAPI does not exist. [-32601]

    Is it only saying that because it can’t connect to xmlrpc?

    Plugin Support Fotis

    (@fstat)

    Hi there,

    Yes, this means that Jetpack cannot connect to your site via XML-RPC. Can you contact your host and ask them if they’re blocking your site’s xmlrpc.php file?

    Okay, so just the one problem then. I didn’t think to ask my provider because Jetpack was working fine before, but I am now in the middle of asking them.

    In the meantime, at the time I was messing with code in .htaccess I also added the plugins WP Optimize and Wordfence. Are those two plugins known to interfere with Jetpack?

    According to my provider, XMLRPC is not being blocked. The XMLRPC validator showed that to be the case.

    I got desperate and uninstalled Jetpack, then disabled every single plugin and reinstalled Jetpack. It connected without a hitch. I then reactivated the plugins one at a time, and Jetpack never lost connection. Although it’s obvious there was a conflict, due to the order I activated them I never found a culprit. Sorry to be such a pain!

    Plugin Support Fotis

    (@fstat)

    I’m glad to hear that Jetpack is now working. Please note that security plugins like Wordfence can interfere with XML-RPC. So make sure to check Wordfence’s Security Options. More info here:

    https://www.wordfence.com/help/login-security/

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.