Support » Plugin: W3 Total Cache » Disabled Page Cache still showing cached page

  • Resolved gmariani405

    (@gmariani405)


    I’ve seen this a few times, but if i have a page that is cached and then disable the Page Caching feature altogether. The cached page will STILL be displayed, with no way to clear the cache short of uninstalling the plugin. I disabled Page Caching on the 16th of this month. I went to visit the site today and it’s still showing the cached page.

    <!–
    Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

    Page Caching using disk: enhanced

    Served from: http://www.example.com @ 2020-06-16 16:27:10 by W3 Total Cache
    –>

    What I’ve had to do is enable it, clear the cache, then disable it again just to work around this bug. Please fix this, it’s causing confusion for my clients.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @gmariani405

    I am sorry about the issue you experienced and I am happy to assist you with this.
    The cached pages are located in wp-content/cache/ folder. There is a possibility that those pages were cached in the browser so the advisable thing to do before disabling the plugin is to purge all caches. Alternatively, you can also delete the /cache/ folder manually from the wp-content.
    Thanks!

    Thread Starter gmariani405

    (@gmariani405)

    I did check to see if it was cached in the browser. I opened up a private session and a separate browser to test. But also, you can see it’s been almost two weeks since I disabled the Page Cache feature so any browser cached pages should have expired by then.

    I am aware of the /cache/ folder, but my concern is that when I disable the Page Cache feature, I would expect not to see any cached pages anymore. I should not have to manually delete/empty the /cache/ folder. It is confusing behavior for the end-user.

    Maybe have the plugin automatically purge the cache before disabling the Page Cache system would give the desired behavior.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Disabled Page Cache still showing cached page’ is closed to new replies.