Support » Plugin: Print My Blog - Print, PDF, & eBook Converter WordPress Plugin » disabled html is included by Print My Blog

  • Resolved cedialogs

    (@cedialogs)


    Blocks of disabled html are included in the output of print my blog. Example css and HTML:

    code in the css file:
    #xxx{display: none;}

    html:
    <div id =”xxx”>
    <p> Print my blog should not print this sentence, but it does.</p>
    </div>

    The div block is included in many posts. once per post. The object of the game is to be able to enable or disable all these blocks from one central point.

    I recognize that fixing this issue could be quite messy, so if there is a better way to enable or disable a block from one central point I would love to know about it.

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Michael Nelson

    (@mnelson4)

    Ah 😱! @cedialogs, sorry I missed this until now.

    So you’d like for that div to be hidden in printouts, but shown normally on the website, right?

    You can add the CSS class pmb-screen-only to the div (or Gutenberg block) and that should make it not appear in Print My Blog’s paper, PDF or eBook output. [There’s a FAQ about this with a video.](https://wordpress.org/plugins/print-my-blog/)

    Or maybe it would be easier to just use the HTML you already have, and just modify your custom CSS. If that’s the case, you could have CSS like this to only match stuff from the Print My Blog print page:

    
    body.pmb-print-page #xxx{display:none}
    

    That works because on the Print My Blog print-page, the CSS class “pmb-print-page” is added onto the body tag; but its not added anywhere sel.

    I hope that helps!

    Plugin Author Michael Nelson

    (@mnelson4)

    Closing due to inactivity. I hope my earlier response helped.
    If your still having trouble, please reopen this issue and we can keep debugging.

    Take care @cedialogs !

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘disabled html is included by Print My Blog’ is closed to new replies.