Support » Plugin: Freesoul Deactivate Plugins » Disabled elementor and pages just went blank

  • Resolved tb99

    (@tb99)


    Hi, I’ve installed the plugin and attempted to use it on my multi-vendor marketplace site (I use Woocommerce Product Vendors). I disabled elementor and elementor pro on all my vendors’ store pages (Terms Archives / Vendors (Products)). However, those pages have now just gone completely white. Can you tell me how to fix this please? thank you

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jose

    (@giuse)

    Hi @tb99

    thank you for opening a thread.

    Are you sure you don’t have another plugin depending on Elementor? Or the theme?

    I suggest the following:
    – Reactivate Elementor and Elementor Pro and save the options
    – Check that all is ok
    – Now, use the lens icon for preview and don’t save the options until you don’t find the problem, so other people will not see a blank page.
    – Disable Elementor and Elementor Pro in preview mode (check the preview with the lens icon)
    – Switch to the default WordPress theme selecting it from the dropdown list (always preview mode)
    – Disable a plugin after the other until you don’t see anymore the blank page.

    Maybe the code of another plugin or the theme triggers a fatal error if Elemntor is not active.

    Let me know if you find something. If not so, I will give you other suggestions to find the problem.

    tb99

    (@tb99)

    Hi,

    Thanks very much for that. Something strange happened, though. The issue seems to be with the theme that I am using (Astra). When I uncheck elementor and elementor pro and preview with a different theme, the screen looks good (like my normal page but without the elementor components).

    However, I can only change the theme in preview mode. Is there a way to change the theme for these specific pages in the live mode?

    Or can you suggest another solution?

    Thank you

    Plugin Author Jose

    (@giuse)

    With FDP you can change the theme only in preview mode. The goal of FDP is not only disabling plugins for speed optimization, but also for debugging purposes, thus I’ve added this feature.

    I think there are plugins to permanently assign a different theme for Terms Archives.

    In any case, I suggest enabling the debug to understand whats’s the problem with Astra when Elementor is disabled on the Vendors Archive pages.

    Take into account, the problem could be caused by Woocommerce Product Vendors, maybe Astra is just triggering the problem, but it’s not the cause of the problem.

    Many times some plugins cause problems and other plugins or some themes make them visible.

    Of course, you can’t disable Woocommerce Product Vendors, but you can understand more doing the following:

    – via FTP open the file wp-config.php
    – enable the debug with:
    define( ‘WP_DEBUG’, true );
    define( ‘WP_DEBUG_DISPLAY’, true );
    If you already see WP_DEBUG and WP_DEBUG_DISPLAY in wp-config.php, set them to true, if you don’t see them, add the lines above before the comment
    /* That’s all, stop editing! Happy blogging. */
    – use again the preview mode disabling Elementor and using the current Theme
    – instead of a blank screen, you should see an error. I hope this error will give the information needed to go nearer the solution

    tb99

    (@tb99)

    Thanks very much Jose! Great app and great help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disabled elementor and pages just went blank’ is closed to new replies.