Support » Fixing WordPress » Disable wordpress reupload renaming

  • Hello Everybody,

    I’m having an issue in re-uploading images onto my WordPress with the same filename where the file being uploaded is appended with a -1 suffix in its filename.

    I did research a lot to find a fix for this, But all of the related posts didn’t help or didn’t work for me Including waiting for 24 hours for the WordPress cleanup to flush the db.

    Reference was from this page : https://en.forums.wordpress.com/topic/how-do-i-stop-incremental-naming-in-media-library/

    I tried the following plugins –
    https://wordpress.org/plugins/media-file-renamer/
    https://wordpress.org/plugins/enable-media-replace/

    Also ran following queries in my MYSQL console to clear attachments –

    DELETE FROM wp_postmeta WHERE post_id IN (SELECT id FROM wp_posts WHERE post_type = 'attachment');
    DELETE FROM wp_posts WHERE post_type = 'attachment'

    And yet it didn’t fix the rename.

    Please help. Thanks.

    • This topic was modified 1 week, 6 days ago by cassiopere.
    • This topic was modified 1 week, 6 days ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic
    • This topic was modified 1 week, 6 days ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic
Viewing 1 replies (of 1 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Install the plugin “Enable Media Replace”. When uploading, it adds the option to replace existing files rather than have the new ones renamed to avoid a conflict.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.