Support » Plugin: Jetpack by WordPress.com » Disable WordPress.com Login

  • Resolved bobbybosler

    (@bobbybosler)


    Hello there,

    I’ve posted about this previously, but because someone hijacked my thread, the moderator marked it as resolved, though my issue was never resolved.

    My WordPress.com login option re-enables itself after a short period of time no matter how many times I disable it. I deleted the plugin and started with a fresh install, but it still re-enables itself after a while.

    Is there some kind of hook or filter I can use in functions.php to permanently disable this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    This most likely happens because a plugin on your site (it could be a plugin installed by your hosting provider) force-enables the Secure Sign On module on each update. The MOJO Marketplace plugin, for example, will do that for you.

    You could try to find what plugin does that on your site and disable it, or you could add the following code snippet to your site, using a functionality plugin as explained here:

    
    /**
     * Force-disable Jetpack's SSO feature.
     *
     * @param array $modules Array of active Jetpack modules.
     *
     * @return array $modules Array of active Jetpack modules.
     */
    function jetpackcom_support_disable_jetpack_sso( $modules ) {
    	$found = array_search( 'sso', $modules, true );
    	if ( false !== $found ) {
    		unset( $modules[ $found ] );
    	}
    	return $modules;
    }
    add_filter( 'option_jetpack_active_modules', 'jetpackcom_support_disable_jetpack_sso' );
    

    I hope this helps.

    bobbybosler

    (@bobbybosler)

    Great! Thanks for the quick reply. I’ll post a new topic if it re-enables itself again.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.