Support » Fixing WordPress » Disable “Welcome to the block editor”

  • I run a vanilla WordPress site with no plugins and only stock themes.

    I need to disable this “Welcome to the block editor” dialog box that popups every time I login in. I don’t need to be reminded what it is or what it’s for. I’ve been using WordPress since 1.2, much longer than this annoying dialog box.

    There’s no option to checkoff on “never show this dialog box again” as well as to disable it in Settings > Writing

    Please advise. Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator t-p

    (@t-p)

    I have the same problem.
    @tp, the link you show has a dead end and no solution.

    Everytime I open my WordPress site I see this message, it’s SO annoying, and still no solution is known? It’s difficult to understand.

    Anyone else who has a good tip?

    Same problem here. That linked thread above is closed and the advice is no longer valid anyway as of WordPress 5.8. (at least) It seems this infernal pop-up is triggering off a missing cookie. If that is the case, it is absurd. I trash cookies after each session. That shouldn’t subject me to infinite pestering. If you are going to get in my (the user’s) way of doing my work, do it once and then honor my dismissal of your intrusion. That’s just being polite, and good UI/UX. Relying on a cookie, is a very bad idea.

    Until this gets fixed, anyone have any guesses? (I suppose I can try blocking the element with Ublock Origin, but I have that turned off while on my Admin sites for a good reason as I don’t want to have to waste time making special rules for sites I should already trust, **because I run them**)

    @adrien, I totally agree.

    As a ‘work around’ I now use the plugin ‘Disable Welcome message’, and that works for now.

    phixate

    (@phixate)

    @yolandal LOL. A plugin to disable a welcome message. Sigh. I guess WordPress has better things to do.

    Tom Greer

    (@tomgreer)

    A plugin is required to disable this popup that appears every time I add a post or page?

    Good website design practice would be to provide a “Don’t show again” checkbox. C’mon WordPress!

    jeffersonreal

    (@jeffersonreal)

    If I get welcomed to the block widgets much more, I might welcome my fist to the screen 🤡

    It is still a nice way to show, how to get UX bad and Users angry and not like a software. A pop-up. Welcome to the 90s.
    I can’t believe I’ve been seeing this for two full years now.
    But there is hope: someday in WordPress Version 6.x we might see User-Preferences saved and not click and click and click and click and click…

    This is extremely annoying to have to dismiss over and over

    Thread Starter danskoya

    (@danskoya)

    “Say hello to “Arturo” and WordPress 6.0…With nearly 1,000 enhancements and bug fixes, the second major release of 2022 is here.”

    Still no solution provided to have permanency with removing these annoying little critter. It still chokes because I don’t need my website to contact s.w\.org every time I login.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    This topic is over a year old… closing.

    If you want to post soemthing where the WP devs will see it and maybe change something, create a ticket at core.trac.wordpress.org.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Disable “Welcome to the block editor”’ is closed to new replies.