Support » Theme: start » Disable webfont.js library

  • Resolved Tom

    (@shimsa)


    Hello,

    when I discovered the StartWP theme, I was excited. Just what I was looking for. Thank you very much!

    Only one thing bothers me. Because I’m loading the fonts locally, I’d like to be able to turn off the webfont.js library.

    Thanks for consideration.

    Tom

Viewing 5 replies - 1 through 5 (of 5 total)
  • Theme Author Munir Kamal

    (@munirkamal)

    Hi,

    Thank you for trying the theme and I am glad you like it.

    That is a good point you have. For now, you can simply dequeue the script with a function.

     function swp_dequeue_webfont() {
    wp_dequeue_script( 'webfont-loader', 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js', array(), KIRKI_VERSION );
    }
    add_action( 'wp_footer', 'swp_dequeue_webfont', 11 ); 

    However, I have noted this as a feature request too. In a future release, I will add an option to disable Google Fonts completely.

    Hope this helps. Let me know please how it goes.

    Cheers,
    Munir

    Hi,

    Okay, I’ll wait for the theme to be updated.

    But please leave the option to set the required Google fonts. In CSS, it will be noted which font is used for which theme area. However, the Google fonts would actually be dropped (a checkmark in the template settings) and local fonts would be used for rendering. Is this realistic?

    Sorry for my English.

    Thank you.

    Tom

    Theme Author Munir Kamal

    (@munirkamal)

    Hi,

    Your actual request to disable webfont.js can be achieved right away with the function I provided.

    Related to better font management, that is something I plan for a future release, but not in the immediate next update to be clear. Let me think of a better solution I can put in place which makes font management super simple and also doesn’t add any bloat.

    Hope this clarifies it. If you are able to disable the webfont.js library, could you please mark this post as resolved?

    Also, if you got more ideas/suggestions, please do pass my way.

    Regards,
    Munir

    Hi,

    I have really solved it simply by using the “Code Snippets” plug-in. It works beautifully. That’s what I needed. Now I’m happy 🙂
    In the future, if this could be possible without the “Code Snippets” plug-in, it would be even better.

    However, I highly praise the support of webfont.js, it is definitely useful, and although I am using local fonts now, I am very glad to have this option.

    Thank you very much.

    Tom

    Theme Author Munir Kamal

    (@munirkamal)

    Hi @shimsa,

    Glad the issue has been resolved for you. And surely it on my roadmap to integrate better font management options as I mentioned. If you got any further feedback/feature requests, please do pass my way.

    And if you are happy, I will really appreciate getting a review on this new theme. 🙂
    https://wordpress.org/support/theme/start/reviews/#new-post

    Cheers,
    Munir

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Disable webfont.js library’ is closed to new replies.