Support » Plugin: Plugin Organizer » disable this plugin on single page?

  • Resolved arathra

    (@arathra)


    The plugin works great on my site — except for a couple of pages.

    I use Ultimate Member (UM) and on the login page I have the regular login along with social login (via Facebook/Instagram, etc) – this social login is a separate plugin from UM.

    When Plugin Organiser is turned ON, only the regular login displays; when Plugin Organiser is turned OFF, the regular login displays along with the social login buttons.

    Now, I went to the login page and ticked OVERRIDE POST TYPE SETTINGS and then took ALL the STANDARD DISABLED plugins out and made them available. (There are no other disabled items visible.)

    But the page still only displays the regular login without the social login buttons.

    It seems – somehow – that Plugin Organiser is blocking the UM Social Login plugin even though it does not appear to be disabled at all.

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    Go to the settings page and use the plugin search to see where you have the UM Social Login plugin disabled. Sounds like you have it disabled somewhere. You can also turn on debug messages to see what is affecting the page you are currently viewing.

    The problem persists. I removed all the Global Disabled settings, all the post disabled settings etc and whenever the plugin is activated the UM Social Login buttons disappear (and there are one or two other problems as well – some forms don’t load properly).

    Is there a way to completely delete ALL the settings for the plugin so I can effectively start from a clean install to see how that works?

    Plugin Author Jeff Sterup

    (@foomagoo)

    Yes. Remove Plugin Organizer from the wordpress plugins page and it will remove all settings from the database. Then reinstall it and it will be fresh install.

    Plugin Author Jeff Sterup

    (@foomagoo)

    This could be ajax related. Some plugins use the root URL as their ajax endpoint. you might have the plugins disabled on that URL so their ajax functions don’t work. Woocommerce does this. If you disable it on the homepage it stops working.

    I’m not sure what to do now. I completely removed Plugin Optimiser, then reinstalled it from scratch.

    Without it the UM Social Login buttons appear fine. When PO is activated, the buttons disappear.

    This is without PO having any settings made.

    The only way I can have the two running together is if I DISABLE custom post type support for PAGES in the PO settings. This is a shame as the pages are where I’d like to selectively load plugins.

    Can you perhaps suggest something else I can try here?

    Plugin Author Jeff Sterup

    (@foomagoo)

    I’m pretty busy all weekend but if I get a chance I’ll download the um social plugin to test it on my site. Itmight not be until Monday.

    Thank you for your help, Jeff!

    Plugin Author Jeff Sterup

    (@foomagoo)

    There is no plugin in the repository named UM Social Login buttons. What is the actual name of the plugin? I guessed that you were referring to Ultimate Member. If so what page are you expecting the social buttons to be on and how do I get them to appear there?

    Plugin Author Jeff Sterup

    (@foomagoo)

    Ok so I think you might be referring to a paid extension for Ultimate Members. I don’t own it so I can’t troubleshoot it. I would go to the group and order plugins page and change the extension to load before Ultimate Member and vice versa. See if that fixes the issue.

    Thank you for all your help!

    In the end, after many hours playing around, it turned out to be a conflict with Litespeed cache. It was difficult to turn off LS. I had to deactivate PO then deactivate LS; which then showed PO as activated.

    And then the UM Social Logins displayed.

    I’m not 100% sure what was happening but presumably there was a cache conflict? Does PO cache anything?

    Anyhow, it’s working now and I’ll keep an eye on it to see what happens next!

    Thanks again (for a great plugin!)

    Plugin Author Jeff Sterup

    (@foomagoo)

    No. PO does not cache anything. But often times with caching plugins they cache the list of active plugins and it can cause headaches with PO.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘disable this plugin on single page?’ is closed to new replies.