Support » Plugin: Freesoul Deactivate Plugins » Disable the command line message

  • Resolved symisz

    (@symisz)


    I like the plugin, I used a similar plugin before it got deprecated. Now how can I remove the plugin message showing up in my command line every time?
    ” <!– Freesoul Deactivate Plugins disabled 0 plugins on this page –>”

    Aside from cluttering the terminal, the message is not really helpful as it only mention global deactivates plugins and not the ones that are specifically deactivated on conditions.

    Thank you for making this plugin available.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jose

    (@giuse)

    Hi @symisz

    thank you for your thread.

    That comment appears in the HTML on the frontend and theoretically, you should see it only if you inspect elements and not in other places. What do you mean that you see it in the command line? Can you please share a screenshot?

    If you see that message, you should also see other HTML comments added by the theme or other plugins. Do you see only the comment of Freesoul Deactivate Plugins?

    The names of plugins are not written because some users may not like that other people inspecting elements can see the names of disabled plugins, but it helps to see if the plugin has disabled some plugins or not so.

    If you are interested to see the name of plugins, you have the “eye” icon going over the page row with your mouse (in the FDP setting pages), then you will see the names in the JavaScript console of the opened tab (Inspect Elements => Console”).

    Thanks for getting back to me @giuse

    Here is the screenshot of my terminal:
    https://ibb.co/0XQkWG0

    I use WP CLI to operate WordPress throught the command line.
    And your plugin message popups in there, might be not intended.

    However being able to operate your plugin through the command line would be an awesome feature!

    • This reply was modified 4 months, 4 weeks ago by symisz.
    Plugin Author Jose

    (@giuse)

    You are welcome @symisz
    Please try the new version 1.8.0 I’ve right now published and let me know if you still have this issue.

    Plugin Author Jose

    (@giuse)

    HI @symisz test it later, I see the zipped package is an old cached version. If you test it now the activation will not work. I think in a few minutes it should take the updated package and should work.

    @giuse that was fast and it worked nicely! thank you!

    i should mention that people should clear their cache as well: wp cli cache clear
    as i still got the plugin message before the cache clearance.

    • This reply was modified 4 months, 4 weeks ago by symisz.
    Plugin Author Jose

    (@giuse)

    @symisz

    perfect, you are welcome.
    You are right, if someone has installed it via CLI command while the repository cache was serving a not updated zip package, you need to clear the CLI cache as you have suggested. Thank you very much to mention it.

    I have already seen that via CLI a PHP warning is triggered, this will be fixed in a future version, it is not a blocking point and you can ignore it. With future versions, you will not see it anymore.

    So I will close the thread, if you have any issues don’t hesitate to open a new one.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.