WordPress.org

Forums

Testimonial Rotator
Disable "Testimonials" Archive Page (5 posts)

  1. marcelbrown
    Member
    Posted 1 year ago #

    The fact that this plugin automatically creates an archive page for the custom post type "testimonials" is troublesome when I want to create a page called "Testimonials" that uses a short code. Is there any way to disable the automatic archive page?

    Thanks!

    http://wordpress.org/plugins/testimonial-rotator/

  2. Hal Gatewood
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, this does need to be a setting. I'll add a filter in the next release for this. If you want to do a hotfix you can go into the file testimonial-rotator.php and at line 104 change 'has_archive' to false

    'has_archive' => false,

    Thanks for reporting this. The problem has popped up before.

  3. marcelbrown
    Member
    Posted 1 year ago #

    Thanks for the quick response! I actually did try that change before I posted my question. But when I tried pulling up the page I had named "Testimonials" it looked like WordPress simply redirected my request to the home page. So I figured there had to be more to it.

  4. Hal Gatewood
    Member
    Plugin Author

    Posted 1 year ago #

    You might have to go into 'Settings' -> 'Permalink' and click save again after you make the changes. That should flush the system.

  5. chrisbjensen
    Member
    Posted 1 year ago #

    I have now changed 'has_archive' to false, and I've updated Permalink but it does not seem to work anyway..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags