Support » Plugin: WooCommerce » Disable (slow) WooCommerce Analytics

  • Resolved YuriV

    (@yuriv)


    Some time ago we uninstalled the ‘WooCommerce Admin’ because it made our backend slow. We didn’t miss it.

    This morning we updated WooCommerce to version 4.0. To our surprise some sort of ‘Woo Admin’ seems to be built in this new version. Am I right?

    The Woo-analytics tool is pretty slow on our site. Charts take a long time to load (even while we’re in test-mode and have only on registered order).

    Is there any option to disable this function?

    Thanks in advance, Yuri

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter YuriV

    (@yuriv)

    Sorry, found the solution for this elsewhere in the forum: https://wordpress.org/support/topic/new-4-0-dashboard-is-so-bad/

    add_filter( 'woocommerce_admin_disabled', '__return_true' );

    Plugin Author peterfabian1000

    (@peterfabian1000)

    Sorry to hear you’re having issues. We’ll be working on improving the performance, so we hope we can make these useful to you.

    What you have found is correct, that is the way to disable WooCommerce Admin from 4.0 onwards.

    add_filter( 'woocommerce_admin_disabled', '__return_true' );

    This is the wrong solution! This code does not work

    Thread Starter YuriV

    (@yuriv)

    Where did you place it? It’s working on our install.

    functions.php

    Hi there,

    @amirrezasr

    You can also use this plugin, which is more convenient to install:
    https://wordpress.org/plugins/disable-dashboard-for-woocommerce/

    Cheers!

    i can confirm this is wrong solution. doesnt work.

    O M G … The increase in speed with @ospiotr’s plugin is huge! I have been suffering (yes, that’s how it feels) from bad performance (and crashes / offline) for some time and could not pinpoint it. Now, with a lot of time on my hand I started digging and found 500’s coming from “/wp-json/wc-analytics/…” in effect generating a whole flow of errors after it, resulting in my site going down (DB issues).

    Simply disabling something I never wanted in the first place (and was unaware of its presence removed my problems..

    We just updated to Woocommerce 4.0.2, or whatever the latest version is. My web guy says these Analytics are great, but….most of the pages won’t load. How do I get the stats to load? They just think about it, and even an hour later, they are still just buffering. Seems like great tools, but won’t load.

    I saw where to import historical data, but the revenue, orders and taxes stats won’t load. The others do.

    I’ve just registered to say that this plugin solved all the slow load issues on my website. So bad that WooCommerce Analytics are not very polished on the server side. They seem very useful and pretty, but are not worth at this cost. My website users were desperated because of the slow WP-Admin panel, and after this, it worked like a charm again.
    Thanks a lot for the solution to disable them!

    Simon Kane

    (@simonkane)

    Problem STILL EXISTS out here in the real world.

    rwsheffield

    (@rwsheffield)

    The analytics won’t even load. Something is wrong and we can’t be the only site with this problem. Is it a conflict with another plug-in? There has to be a solution.

    The Revenue and Orders tabs show nothing. The products tab shows the graph, but without any supporting product info.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Disable (slow) WooCommerce Analytics’ is closed to new replies.