Support » Plugin: Shortcode in Menus » Disable Shortcode in Mobile Menu

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Gagan Deep Singh

    (@gagan0123)

    @tazcrzy

    Can you provide more info about
    1. What shortcode you’re using?
    2. What menu you’re trying to prevent it from being visible?
    3. From which plugin the shortcode is coming?
    4. Which theme you’re using?
    5. How many menus the theme has?

    Just answer the ones that you know of, rest, we’ll try to figure out.

    Thread Starter tazcrzy

    (@tazcrzy)

    We are using [menu-XX] xx because we have 3 different ones we are using. Trying to hide only on the mobile menu. The shortcode is coming from your plugin “Shortcode in Menus”. We are using Themefuse Unyson/Core. We have a left and right menu with this website. Here’s the url to the website: glenellynfoodpantry.org. We are trying to remove Menu Capital, Menu Donate, Menu Newsletter and Social Shares from the hamburger menu in a mobile view.

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    @tazcrzy

    You can edit the shortcode menu item, and add a span tag wrapper around the shortcode, having class nomobile something like this:

    Then in your CSS add this

    
    @media only screen and (max-width:600px){
    .nomobile{display:none;}
    }
    

    This would prevent that shortcode output being displayed in mobile menu.

    In case you can’t find out how to edit shortcode once you added it, here’s how:

    Thread Starter tazcrzy

    (@tazcrzy)

    Thank you for your suggestion, however it did not work. I am still seeing these shortcode menus in our hamburger menu on mobile devices. Anything else I can try?

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    @tazcrzy

    Sorry for the delayed reply, I usually get only weekends to check the support tickets.

    About the issue, have you added the shortcode within the span as I mentioned?
    <span class="nomobile">[menu-xxx]</span>

    And are you certain the CSS as I mentioned is there as well?

    If those two things are correct, then maybe you can try modifying the CSS like this:

    
    @media only screen and (max-width:800px){
    .nomobile{display:none;}
    }
    

    If that also does not work, then try this out:

    
    @media only screen and (max-width:800px){
    .nomobile{display:none!important;}
    }
    

    Let me know if you get it to work or not. Would be happy to help you out further if needed.

    Thread Starter tazcrzy

    (@tazcrzy)

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Disable Shortcode in Mobile Menu’ is closed to new replies.