Support » Requests and Feedback » Disable Referrer Security

  • I’m just hoping this gets looked at by someone because I’m sure there is someone else out there who, like me, has done everything imaginable to fix this stupid problem with the “You need to have sending referrers enabled” security, and still not gotten it to work.

    It’s been two days now. I’ve disabled my firewall, fiddled with settings in Firefox (which I do indeed sometimes disable referrers on, so I wanted to make sure my config isn’t bonkers), tried in IE (which I never touch and have certainly never disabled referrers in), rebooted my machine a few times, logged in and out of WP multiple times, tried accessing my site from the typical URL I use (no ‘www.’) and from the ‘www.’ appended version… I’ve even hung from the ceiling by my toes praying to the great Internet Gods… No luck.

    Nothing, nothing will make this go away. This means I can’t activate/deactivate plugins, can’t delete posts, and most importantly, I can’t even change the theme on my site, which is the most pressing issue as I am in the middle of redesigning and would really like to test out my code. Pity, I can’t, because of this ‘security’ that is bonkers and apparently can’t be disabled from within WP.

    I am hoping to god that by the time 1.5 goes live, this problem is either ‘fixed’ or that there is someway to disable it.

    I hate to sound like I’m really pissed off and ranting, because, really, I’m not pissed off. It’s just a massive headache that, to me, should have some sort of relief.

    Now I’m going to go have a good long cry.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator James Huff


    Did I not just say I tried all of that? (Sure, by describing all the specific items, I suppose, but not by saying specifically that I’ve tracked down that page that is posted in every sending referrers post in this forum, so I guess I will say it specifically.)

    Yes, yes I most certainly did.

    (I will also specify that I have Kerio Personal Firewall, 4.1.2 and the option to disable referrals is under “Web” then “Privacy” and the option is called “Deny servers to trace web-browsing” and that I have the option UNchecked, but to further prevent problems, I actually have the master switch, “Enable web filtering” UNchecked as well, to disable all webfiltering. To even be more sure Kerio wasn’t the problem, I have even disabled the firewall completely, which didn’t work, and then even closed the firewall completely, which didn’t work either.)

    Moderator James Huff


    “Did I not just say I tried all of that?”

    No, you didn’t, but good luck.

    “in the middle of redesigning”

    Did this issue suddenly occur ?
    Or has it been apparent since you very first logged into WP ?

    Suddenly occured yesterday, roughly in the afternoon, for no reason obvious to me.

    About two days ago, I had the issue when deleting a post, but going back into Firefox’s options and enabling sending referrers fixed it. (I mentioned I disable it from time to time). Now, nothing I do will fix it.

    macmanx: Thank you for your remarkable generosity, patience, and help. I hope you didn’t strain yourself when you spit that URL at me and then told me to shove off. …Not to sound ungrateful or anything.

    Something in your machine will have changed…

    Windows update ?
    Browser update ? Firewall ?

    None of the above… The only thing that occured inbetween the working and then not working was that I had opened Photoshop and TopStyle and worked on the design. My machine had been logged in about five days at the time the problem began and no system wide changes (or, really, any changes at all) occured before it started happening.

    It doesn’t make any sense, and without any sort of indicators of why the problem might have started there can’t be a fix for it, which is why I’m not really asking for help to solve the problem, I’m just hoping there will eventually be an option to turn off that form of security, even if it has to be extremely moron-proof and disabled by going into some sort of complicated config file and changing a small setting.

    Moderator James Huff


    Try deleting your WP-related cookies and browser cache. You may have all ready fixed it, but your cache or cookies could still be displaying the error. I hope you don’t strain yourself while giving that a try.

    Disabling it is certainly going to be possible, but then how is your site going to know it’s you ? I could go directly to an admin page, and without WP being able to check that I have passed the security check by using a password, it will let me do what I want. Not good.

    Is it just your WP install ? Is there another site that requires referrer checking that you have been to and all is well ? Could you check ?

    Lemme try a variety of sites, I know some torrent sites check referrers to download, and I’ve got a few other sites that I know do too…

    Yeah, those all work… What could be causing it from inside WP? Anything I can eyeball or test? As far as I remember I didn’t enable/disable any plugins between the time it worked to the time it didn’t, and no other modifications otherwise, either.

    Edit: Also, went ahead and followed macmanx’s advice above (indeed something I hadn’t tried, also, it was a bit of a strain, stupid back injury), clearing cookies and the cache, and that didn’t work. (Which I’m really happy about, because I was afraid he was going to be right and I would have to grovel. Course, it means it still doesn’t work, so really, I’m sad.)

    Edit Again: I went ahead and tried the clearing cookies and cache inside IE, as well, and that didn’t work either. ;(

    This is my third day with WP and i anxious to make it in work :). I’m very happy with the possibilities of WP. But my situation is identical to the one of Amiantos.
    If I prove the test in:
    I have the possibility of altering the scheme of WP, typical of admin. That is that does not seem a problem of browser or router (of nonbeing which opensourceCMS has deactivated referrers…)

    Thank you very much by the WP, and ahead (sorry for my english…)

    Moderator James Huff


    If you’re saying that their test installation of WordPress is display the error for you, it isn’t for me. Are you sure that you’ve tried everything here:

    Keep in mind that the list is a work in progress and may not have every possible solution.

    I think he was trying to say that playing on that demo works… Same for me, the demo works, no errors. Must be something quirked in my install. I will go through and see if I can spot any WP files that have changed since I uploaded that probably shouldn’t have. If that comes up with nothing, maybe I’ll just del-&-reupload all of the WP files.

    Edit: Nothing has apparently changed in all my core WP files. I will re-upload everything folder-by-folder and test it and see if I can at least isolate a possible cause. I figure this should rule out whether it’s a WP-code problem… then I’ll go through all my plugins, removing one by one and testing for each one to make sure it isn’t one of those.

    Course, if it ends up that the problem still exists afterwards, I would assume that means something is terribly wrong with my machine somewhere.

    I wish I could have someone else log in to my install and see if they have the same problem.

    Deleted my wp-admin folder completely and re-uploaded… No dice. I think this is where I give up. ;(

    If a developer (or macmanx, if you want) wants to contact me via AIM and discuss the possibility of them testing out my install themselves to see if they have the problem (effectively ruling out the possibility of it being my machine), please do so. My SN on AIM is ‘Amiantos’ … MSN would be ‘’.

    sorry for my confused english… yes, if i test in opensourceCMS i not have errors. The referrer error is only in my installation.
    Yes, i have read and applied the
    with Linux and XP and three differents browers: FireFox, Opera an IE.
    maybe the referrer error a problem with my provider hosting?
    Thanks !

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Disable Referrer Security’ is closed to new replies.