Support » Plugin: Jetpack by WordPress.com » Disable Portfolio (Because I want to use /portfolio/ for something else)

  • Resolved greysonwhy

    (@greysonwhy)


    I originally posted this here, but I realized that it’s likely not a problem with the Orvis theme but either with WordPress or Jetpack. Then, I posted it here and it was recommended that I ask you all!

    Is there a way that I can completely disable Portfolio or at least the Portfolio Archive Page? Or can I change the /portfolio/ slug to something else? I have no use for the Portfolio and would like to use that link for a regular page. I know that I can disable Portfolio through the Jetpack settings, but, even after doing that, https://greyson.conlang.org/portfolio/ just redirects to the home page instead of going to the page that I have set up for it, which would look like https://greyson.conlang.org/portfolio2/.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support darnelldibbles

    (@darnelldibbles)

    Hi there,

    I would try this plugin and see if it does the trick:

    https://wordpress.org/plugins/permalink-manager/

    I know that it has worked in the past for others with the same issue.

    Let me know if that does work for you.

    Thanks!

    That got me close, I think. It seems to only allow me to change the link for the individual Portfolio Projects but not for the Portfolio Archive Page, which is what I’m trying to change.

    Furthermore, I even tried deactivating Jetpack completely, but https://greyson.conlang.org/portfolio/ is still redirecting to https://greyson.conlang.org/ and not showing me the page that should be there.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    At any point did you use any other plugin that would have provided portfolios?

    Being forced to use /portfolio2 is interesting, because it means that /portfolio already exists somewhere else, maybe as a Page or Post title even.

    As far as I know, /portfolio is the Portfolio Archive Page when I have the Jetpack Portfolio turned on. The tab is called “Projects — Greyson’s Conlang Blog”, so, if I actually had any Portfolio Projects, all of them would show up there. When I don’t have the Jetpack Portfolio turned on, it just redirects to the homepage as if there’s some invisible page still called /portfolio that redirects to the homepage, which is where I am lost.

    Have I used any other plugin that would have provided portfolios? No; not that I can remember, at least. I definitely don’t have any installed right now.

    I’ve tried deactivating Jetpack, clearing the cache, and using the above plugin. That’s all I can think to do. I’m not very knowledgeable when it comes to this stuff.

    Plugin Support Fotis

    (@fstat)

    Hi there,

    I have already replied to your other thread in the Orvis theme support forum:

    https://wordpress.org/support/topic/disable-portfolio-because-i-want-to-use-portfolio-for-something-else/#post-11747451

    This is what you need

    https://wordpress.org/plugins/jetpack-module-control/

    but only if you know what you are doing 🙂

    @fstat, unfortunately, neither of those work. I had already tried Permalink Manager, but it doesn’t show /portfolio. I can only assume it’s some special kind of page that doesn’t show up in the free version as the Portfolio Archive Page doesn’t show up whether I have Portfolio enabled or not. There’s nothing in Projects, nothing in Pages. I’m not sure if I can justify spending $42 to fix this problem. As for Permalink Customizer, it has even less functionality.

    @aimarv, unfortunately, that didn’t work either. I used it to disable custom content types, but I still have the same problem, https://greyson.conlang.org/portfolio/ still redirects to the homepage and not to the page I have created.

    Actually, immediately after sending that, I went back to messing around with things to see if I could stumble onto a fix. I renamed the /portfolio to something else and then back, which seemed to fix it. Now, I swear I have done this multiple times before to try to reset the page. So, it seems that @aimarv was right! Disabling the module completely seems to have freed up /portfolio. I have to head to work, but I’ll check it again later to make sure that was what fixed it before I mark this as resolved.

    Plugin Support darnelldibbles

    (@darnelldibbles)

    Hopefully that diid it, but keep us updated!

    Okay, wait. This is so bizarre. I’m thinking that @darnelldibbles and @fstat may have been right this whole time. So, I deactivated Jetpack Module Control and reënabled Jetpack Portfolio. Then, I disabled Jetpack Portfolio again. I was able to reproduce my own problem of /portfolio redirecting to the homepage. Off to a good start! I disabled Jetpack Portfolio. Still redirecting. Okay, that’s what happened last time. Then, I used Jetpack Module Control to disable custom content types. Still redirecting. I thought so. Then, I changed the /portfolio slug and changed it back. Like before, it worked after doing that.

    I wanted to be even more thorough, however. I reënabled custom content types through Jetpack Module Control, uninstalled Jetpack Module Control, and turned Jetpack Portfolio back on. Why? I had an idea. I changed the /portfolio slug and changed it back. It worked—yes, even with Jetpack Portfolio enabled.

    Now, I don’t know why. At this point, I have to assume it was Permalink Manager. Which is weird, right? I didn’t mention touching that once—because I didn’t! With Permalink Manager installed, changing the /portfolio slug and changing it back makes it work.

    Why? I don’t know. But I’ve spent enough time on this, and now I’m just happy that it works and I hope I’ve done enough to help anyone else who might have this problem.

    Thanks to everyone for being so helpful. I’ll copy this for my other threads.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.