Support » Plugin: Plugin Organizer » Disable Plugins on Post Page is not working… why?

  • Hi,

    the settings I saved has no effect on my site – or I don´t understand it 🙁

    For example: in “Post Type Plugins” and “Post Type = Post” I have the plugin “Instagram Feed” moved to the “Disable Standard” Section.

    I also have “Selective Plugin Loading” = ON and the MU plugin file is within the folder /wp-content/mu-plugins

    But when you open my post page, you can see that Instagramm is still showing:
    https://one-million-places.com/reiseberichte/mittelamerika-karibik/antigua/nelsons-dockyard-fort-berkeley-antigua

    I have also tested this with other plugins. No effect.

    When I move a plugin on “Post Type Plugins” with the “Post Type = Page” everything works fine.

    My questions:

    – is it normal there there are no other files in the folder mu-plugins? There is only the PluginOrganizerMU.class.php file

    – the “last change” date of the PluginOrganizerMU.class.php stays always on the date when I have copied that file. Is this ok?

    Do you have any idea what can be the reason that I can´t disable plugings on my post pages?

    Michael

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    Go to the post edit page of the post where you still see the Instagram plugin being loaded and check to see that override post type settings has not been checked.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Yes it is normal to only have the Plugin Organizer file in the MU folder. The last change date will always be the date you copy it to that directory.

    Yes, this works.

    But I have more than 320 different posts on my blog – do I have to edit every single post now to disable the plugin??

    I thought “Disable Standard” means that the plugin is diabled in every post automaticly?

    thank you for your fast answer.
    did you saw my second question?

    Plugin Author Jeff Sterup

    (@foomagoo)

    I didn’t mean you had to do that to get it to work. I wanted you to go to the edit screen and see if that had been checked on the post. If it is checked then what you set on the post type plugins page will not have any affect. If you go to the edit screen and it isn’t checked then the plugin should be disabled. If it wasn’t checked when you went to the edit screen then it may be timing out while trying to save the posts. When you hit save on the post type plugins page does it successfully save? Or does it hang and just keep the loading graphic on the screen?

    Plugin Author Jeff Sterup

    (@foomagoo)

    Disable standard means it will be disabled only on non-mobile browsers if you have selective loading turned on for mobile. If you don’t have mobile turned on then it is disabled for all browsers.

    Hi,

    ok, lets try to find the problem step by step.

    Please look at this screenshot:
    Screenshot

    What I have done is the following:

    (1) On the settings page I have added for type=post the plugin “Instagram Feed” to the “Disable Standard” section. Did I understand correctly that this plugin must be disabled now on ALL my posts automatically? Is this right? But it isn´t…

    (2) then I open the edit screen from one of my posts and I have looked if the “Plugin Organizer” is checked. But it isn’t checked. Is this ok or not?

    (3) I hve opend the “Plugin Organizer” settings in my edit screen, check “Override Post Type settings”, saved this post and now it works. The “Instagram Feed” will not be shown in this post. When I now uncheck the “Override Post Type seetings” and save the post again, the “Instagram Feed” is still disabled.

    So at the moment I can disable plugins for a single post – but the “Disable Standard” function is not working. I can´t edit more than 320 posts now…

    The “Disable Standard” function for type=page is working. No problem. But what can be the reason that the “Disable Standard” function for post is not working?

    Hi Jeff… did you saw my last post?

    Plugin Author Jeff Sterup

    (@foomagoo)

    Step 1 should disable the plugin on your post. Do you have any plugins that change the permalink? Are you running any caching plugins?

    I have “SEO Yoast” installed and “Customize upload directory”
    I have a cache plugin, but it´s not active at the moment.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Disable Plugins on Post Page is not working… why?’ is closed to new replies.