Support » Plugin: Redis Object Cache » Disable plugin? Lost content from Woocommerce!

  • Resolved jannedeman

    (@jannedeman)


    When i disable the Redis plugin my Woocommerce product information is gone from all Woocommerce products.
    I have tried do disable all other plugins (to avoid conflics) and the issue is still the same.

    I even have deleted the cache on the server, including the Redis DB.
    Problem still exists. Enabling the plugin will show all productinformation back again (god bless!) So now the plugin is enabled but i cannot disable it anymore!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Hi! I’ve seen this a couple of times before. It usually happens when the cache is disabled for a while, then re-enabled, but not flushed right after.

    I’d screenshot/copy all the critical data and then delete the plugin and fill it all in manually to recover from your situation.

    So, you mean that i should
    -enable the plugin (to get back all the data) and then
    -export 500+ products
    -disable the plugin (data is gone)
    -Import all products?

    Plugin Author Till Krüss

    (@tillkruess)

    This plugin only provides an API for WooCommerce to talk to Redis, so all logic and data is actually handled by WC.

    I don’t know what your exact problem is. It seems like your cache is containing data that should be in your database. If you’re not an expert in this field, I recommend hiring a professional.

    My guess is you disabled the dropin for a while (maybe a few days), then re-enabled it, but didn’t flush your cache, so your database and Redis are out of sync.

    This plugin cannot flush the cache automatically, because it’s a destructive action.

    If you run a business, I’d highly recommend using Redis Cache Pro, because it’s robust and is optimized for WooCommerce.

    It seems i have a solution for all others with this problem:
    ** I am testing with different (in private) browsers do double check if the problem is solved. **
    -Enable plugin (so all productproperty’s are visible and all = ok
    -Export 1 product with the default woocommerce product exporter
    -Disable the plugin. (content is gone)
    -Import the 1 product back again. Yes, overwrite.

    Now all my productpropertys are back again for all products. (so not the only one i exported and re-imported.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.