Support » Fixing WordPress » Disable “password changed” emails

  • Steve

    (@steveholland)


    Every time a user resets their password, the WordPress administrator gets an email.

    The subject of the email is: [Site Name] Password Changed

    Then the body of the email says: Password changed for user: [username]

    I found a snippet on this forum that is supposed to disable this email. Here’s the snippet:

    if (!function_exists('wp_password_change_notification')) {
        function wp_password_change_notification($user) {
        return;
        }
    }

    I have tried placing this snippet in my theme functions file and also I have tried using the “Code Snippets” plugin.

    It doesn’t seem to work. Am I doing something wrong? Is there another method I could try to disable these emails?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi, @steveholland
    please add this code into the functions.php
    add_filter( 'send_password_change_email', '__return_false' );

    Thread Starter Steve

    (@steveholland)

    Hi @wpdkv I’m sorry but that code is not working.

    As the site administrator, I am still getting the password reset notifications every time a user resets their password.

    I have even tried this on a fresh WordPress installation.

    Thread Starter Steve

    (@steveholland)

    Still can’t work this out. The emails keep arriving, several per day. Very annoying!

    How do I disable these emails?

    John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    The send_password_change_email is not the correct filter to use for this email. That filter is for the email that’s sent to the user that changed their password, not to the site admin.

    @steveholland The code in your first post is correct, but it needs to go into a plugin. Putting it into your theme means the code loads too late and does not take effect.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disable “password changed” emails’ is closed to new replies.