WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Disable Page-Sidebar

[Resolved] Disable Page-Sidebar

  • patshi
    Participant

    @patshi

    How to disable the Page-Sidebar in Marketpress?
    The Main-Market-Page has the full-width-page setup, but all other sub-pages ignore this setting and uses the default-page setting.
    How to define that this “invisible” sub-pages also use full-width-page
    setup.

    I dont use a Marketpress theme, I use the workality theme which I customized for my whole wordpress site. This theme features all full-width pages among others, but as I mentioned, marketpress falls back to the default-page setting which features a Page-Sidebar.

    Thanks.

    https://wordpress.org/plugins/wordpress-ecommerce/

Viewing 2 replies - 1 through 2 (of 2 total)
  • David
    WPMU DEV Support Staff

    @ugotsta

    Hi @patshi,

    Hope you’re well today! 🙂

    MarketPress would normally rely on your theme’s single.php file for display purposes and if that file has a sidebar, MarketPress will also.

    You can override that though, using the detailed instructions here:
    http://premium.wpmudev.org/blog/the-easy-guide-to-theming-marketpress/

    Although if your theme allows you to change layouts for other templates, you could try using a full-width layout that way.

    I don’t have a copy of that theme, so I couldn’t tell if it does. Perhaps you can find an option for that?

    Cheers,
    David

    David
    WPMU DEV Support Staff

    @ugotsta

    Hmm, I just thought of something else, definitely not optimal but perhaps an easier way to handle it. You may be able to simply hide the sidebar using CSS.

    If you could provide a link to the site, I may be able to provide that here.

    It’s not optimal as it’d involved hiding the sidebar that’s already been rendered. But for appearance purposes, it typically does work.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Disable Page-Sidebar’ is closed to new replies.