WordPress.org

Forums

Social Author Bio
[resolved] Disable on Product Pages (4 posts)

  1. DebbyK
    Member
    Posted 12 months ago #

    Great plugin, but I can't seem to disable it on product pages. I'm running the most current wordpress and woocommerce. The only way to get it off is to disable for posts, but then it's not on the blog posts, which is exactly where I want it.

    Example: http://www.ttinvent.com/?product=engineering-with-leds-toolbox

    There isn't an option on the product edit page to check off adding social bio. Any ideas how to take this off the product pages?

    https://wordpress.org/plugins/social-autho-bio/

  2. Nick Powers
    Member
    Plugin Author

    Posted 8 months ago #

    Woocommerce must be using post instead of a custom post type to display products.

    One idea I can think of is to disable it for posts and enable it for shortcodes and then add this into your theme:

    <?php echo do_shortcode('[social-bio]'); ?>

    Let me know if that works for you.

  3. souravghosh
    Member
    Posted 7 months ago #

    Hi Nick. I am facing the same issue while working on my client's site. http://nigeltaylor.net/product/hearts/

    Can you please explain the solution you gave in your last reply?

  4. Nick Powers
    Member
    Plugin Author

    Posted 7 months ago #

    If you go into the general settings for Social Author Bio then you can disable all but the shortcode... then you can add <?php echo do_shortcode('[social-bio]'); ?> into your theme template, everywhere that gets called it will display the Social Author Bio.

Reply

You must log in to post.

About this Plugin

About this Topic