Support » Plugin: Animate It! » Disable on Mobile

  • cgscomputers

    (@cgscomputers)


    I have been testing this plugin and noticed that sometimes when Enable on Smartphone is not selected, it still runs the animations on smartphones.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author eleopard

    (@eleopard)

    Hi Cgscomputers,

    Thanks for using the Animate It!

    Regarding your issue, The plugin detects the device in order to disable animations.
    So if you testing this on your PC/Mac by making the screen size smaller, the animations will show.

    And if you are testing this on your phone, the animations would be disabled.

    So, if this is happening on your phone, please share the link to your page as well, so that I can do some troubleshooting.

    Thread Starter cgscomputers

    (@cgscomputers)

    I use it on 2 sites – https://cgscomputer.com and https://allisonspoppinpapa.com and both are showing the animations on an actual mobile device (iPhone 13 Pro).

    Plugin Author eleopard

    (@eleopard)

    Hi,

    We’ll look into this issue. I seems the browser detection script we are using is not working as expected.

    meanwhile you can try this workaround:

    1. In the WordPress backend, go to Settings > Animate It! > Custom CSS

    2. Paste the following and save:

    @media only screen and (max-width: 767px) {
        .animated {
    		-o-transition-property: none !important;
    		-moz-transition-property: none !important;
    		-ms-transition-property: none !important;
    		-webkit-transition-property: none !important;
    		transition-property: none !important;
    		-o-transform: none !important;
    		-moz-transform: none !important;
    		-ms-transform: none !important;
    		-webkit-transform: none !important;
    		transform: none !important;
    		-webkit-animation: none !important;
    		-moz-animation: none !important;
    		-o-animation: none !important;
    		-ms-animation: none !important;
    		animation: none !important;
    	}
    }

    This would stop the animations on mobile.
    Will get back to you as soon as the issue is fixed.

    Thread Starter cgscomputers

    (@cgscomputers)

    Thanks, I haven’t tested the CSS you provided, but I am fine waiting for a working update. It is not yet that critical. Thanks!

    Plugin Author eleopard

    (@eleopard)

    Hi Cgscomputers,

    Sorry I missed to inform you.
    Our latest Version 2.4.1 has updated the detection of Browsers and Devises to handle the blocking on animations.

    The animations should be be disabled properly on mobile devices now, if its set that way in the settings.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.