Support » Plugins and Hacks » WP Supersized » Disable on iPad, Tablet, Mobile

Disable on iPad, Tablet, Mobile

Viewing 15 replies - 1 through 15 (of 18 total)
  • I would like this too. I think it would be a really useful function!

    i would like to know this to

    cant wait 4 a solution

    Hi all,

    me to – wish, we can disable supersized on smaller screens.

    Meanwile i use this workaround:

    I) Put this in your base css:
    #supersized {display: none !important;}

    II) Put this in your css for bigger screens:
    #supersized {display: block !important;}

    …this will help

    Last: If you don’t like the dark background on smaller screens, change the background-color in your base css – e.g. white:
    body {background: #fff !important;}

    Okokok – this workaround wont stop loading the images etc. its only stop displaying… 😉

    hi this solution
    is partial
    i idid it also
    but the mobile website

    is still loading pictures which makes it
    very heavy for mobile

    the best solution is to disable the plugin in some way

    that way on mobile the content will be light weight with no unnecessary
    scrips on the background

    we need to wait for a proper solution from the author


    i think normal solution would be,

    if (Modernizr.touch){
       // bind to touchstart, touchmove, etc and watch <code>event.streamId</code>
    } else {
       // bind to normal click, mousemove, etc

    with modernizr , coz $browser detect in jquery is deprecated, but the problem is :

    The Modernizr.touch test only indicates if the browser supports touch events, which does not necessarily reflect a touchscreen device. For example, Palm Pre / WebOS (touch) phones do not support touch events and thus fail this test.

    or something like this:

    and just remove the jquery scripts or supersized DIV with jquery <script>$("#divname").removeClass("blue");</script>

    somebody got a solution
    fro disabling supersize function on mobile/ipad

    not only hide it
    with a display:none



    Check out @apsolut‘s links and code-solution. Those should do it.

    I use the http://detectmobilebrowsers.com/ and my hack is a change of the WPSupersized.php:
    Add an if within the addHeaderCode()-function after “<script type=”text/javascript”>” like this:
    if(!jQuery.browser.mobile) {

    And close it right before “</script>”

    An admin-option would be nice 🙂

    $.browser is deprecated in jQuery 1.3 , and removed from jquery 1.9, and thats bad for future..


    i have a probelm with the plugin on ipad 3 from some reason
    it crashes everytime i load the page
    that has a lot of pictures like 80

    what may be the probelm
    and how can i solve it

    the probelm happens only on ipad 3


    2much of images, as i remember on ipad3 , the memory is problem, can you reduce number images and try?

    The solution I found was to add this function to your functions.php file within the mobile theme, and then call it from the header file (I called it above all the style sheet registration statements)

    function my_deregister_wpsupersized() {

    You can find the registered scripts and styles inside the file plugins>wp-supersized>includes>WPSupersized.php and then the initialize() function. You’d probably need to update your my_deregister_wpsupersize() function when you update WPSupersized when it has future releases.

    Hello Sefmi,

    I can’t get this solution to work. Can you provide me with your exact code please. I need to figure this out!

    Thank you!

    Yeah, the plugin crashes safari on iphone and ipad…android’s work fine however. Can I just disable for mobile or can this be fixed?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Disable on iPad, Tablet, Mobile’ is closed to new replies.
Skip to toolbar