WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » Disable og:title from being posted – Help please.

Disable og:title from being posted – Help please.

  • Hi,

    I’m using your fantastic Wordress SEO Plugin for my wordpress site, and I’ve also got the Jetpack plugin, which I’m sure you’ve heard of.

    I’ve got an issue in that the og:title content is being posted twice when I use a pluging that auto-posts my posts to twitter/facebook/google plus etc. When my posts go to Google Plus, the og:title is being duplicated.

    I don’t want to disable either your plugin or the Jetpack one, as they provide great features. I’ve tried disabling the Jetpack one, but your plugin does not auto-post the snippet of content like the Jetpack one does.

    I’ve found a way to fix this, by removing this code from the class-opengraph.php file in your plugin:

    <meta property=’og:title’ content='” . esc_attr( $title ) . “‘/>\n

    But I fear this will be overwritten every time the plugin updates.

    Is there a way to disable th posting of the og:title tag from within the console do this does not get overwritten each time you update your plugin.

    Thanks for your help.

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 3 replies - 1 through 3 (of 3 total)
  • mpclark

    @mpclark

    I have exactly the same issue.

    However, I’m seeing both Jetpack and Yoast SEO post a snippet of content as “og:description”.

    To me it looks like Yoast SEO is doing a slightly better job of posting Open Graph attributes. Nonetheless, we need to turn one of these off. Has anyone got any ideas on how to do that?

    RoamFree

    @roamfree

    Yoast wrote about this issue today in his blog: http://yoast.com/jetpack-and-wordpress-seo/ and in the comments one can see that the problem is being worked on.

    mpclark

    @mpclark

    That’s very responsive support, writing an entire blog post about my question moments before I even asked it 🙂 Thanks, RoamFree, for the steer.

    FWIW I had to add *both* the filters shown in that thread before the Jetpack OG tags went away.

    This is what I added to functions.php:

    // stop Jetpack plugin from adding its own Open Graph tags -- leave it to the Yoast SEO plugin
    
    add_filter( 'jetpack_enable_opengraph', '__return_false', 99 );
    add_filter( 'jetpack_enable_open_graph', '__return_false', 10, 3);
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Disable og:title from being posted – Help please.’ is closed to new replies.
Skip to toolbar