Support » Plugin: WP ULike - Most Advanced WordPress Marketing Toolkit » Disable Notification Toast for Buddypress

  • Resolved contemplate

    (@contemplate)


    We have enabled the Notification custom toast on our site but we only want to use them for Posts and not Buddypress likes. Is there a hook or filter to disable them for Buddypress likes?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Alimir

    (@alimir)

    Hi @contemplate
    Thanks for your suggestion, We will add this feature in the next update. 🙂

    Thread Starter contemplate

    (@contemplate)

    Perfect!!

    Plugin Author Alimir

    (@alimir)

    @contemplate Done. 🙂

    Thread Starter contemplate

    (@contemplate)

    @alimir thank you .. but I found one bug.

    I disabled the Toast on Buddypress activity and comments but now when we press the Heart on a buddypress activity it does the animation but never turns red. If I then refresh the page it shows the activity as liked but the JS seems to never turn it red by itself.

    Thread Starter contemplate

    (@contemplate)

    Oh and when I disable the Toast globally the Buddypress activity likes go back to working as normal.

    Plugin Author Alimir

    (@alimir)

    Hi @contemplate
    Sorry about that! That’s an issue with option value.
    We will fix this problem in the next update. However, until then you can fix it by making a simple change on the following path:
    wp-content/plugins/wp-ulike/inc/classes/class-wp-ulike-setting-repo.php
    Modify getOption function as follow:

    	protected static function getOption( $key, $default = NULL ){
    		$option = wp_ulike_get_option( $key );
    		return $option != '' ? $option : $default;
    	}
    

    I couldn’t disable Custom Toast Notifications.

    Issue fixed… It is working like a charm 🙂

    Thank you…

    Thread Starter contemplate

    (@contemplate)

    @alimir that doesn’t seem to fix the bug we are facing… actually with the patch applied and the Toast fully disabled our likes do not fully flip over. This only started happening with this latest version.

    I recorded a short walkthrough here:

    (1 min)

    Thread Starter contemplate

    (@contemplate)

    @alimir I rolled back to version 4.4.2.1 the the issue above is resolved. I’ll wait for a fix in the next release hopefully.

    Plugin Author Alimir

    (@alimir)

    @contemplate Oops! I found this problem occurs when the Hide Counter Value option is on! In the new update that will be published in the next two days, we will solve this problem. 🙂

    Thread Starter contemplate

    (@contemplate)

    Oh awesome! Thanks for such quick responses.

    Same issue here. Waiting for next update.
    Thank you.

    Plugin Author Alimir

    (@alimir)

    @venteens @contemplate
    Please try our new update. (V4.4.4)

    Thread Starter contemplate

    (@contemplate)

    @alimir it works!! Thank you for your quick response on this.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.