Support » Plugin: AMP » Disable lightbox on images

Viewing 11 replies - 1 through 11 (of 11 total)
  • Renee Johnson

    (@reneesoffice)

    @douglasferraz89 thanks for your topic!

    You may be experiencing something similar to this known issue.

    On AMP pages with the issue, do you have the Add lightbox effect toggle under AMP Settings in the editor’s image block turned off on all your images? Feel free to share an example URL as well.

    Thread Starter Douglas Ferraz

    (@douglasferraz89)

    @reneesoffice

    Exactly the same problem.

    All images are turned off.

    I am testing on localhost and I am using AMP In Standard Mode.

    The Slim SEO Plugin is responsible for causing this. The plugin is inserting this in the images.

    i-amphtml-auto-lightbox-visited="" lightbox="i-amphtml-auto-lightbox-1" on="tap:amp-lightbox-gallery.activate"

    Thread Starter Douglas Ferraz

    (@douglasferraz89)

    This problem I reported happened when the Slim SEO plugin is active.

    The problem happens when Facebook open graph is activated.

    It is one of the plugin modules.

    @rilwis

    I have listed the developer here, if it is a problem, I can open a topic in the plugin forum.

    Renee Johnson

    (@reneesoffice)

    @douglasferraz89 thanks for the reply! While I’m seeing the same behavior with and without that other plugin on my test site, the initial issue looks to be related. Feel free to subscribe to the issue to keep up to date on its progress.

    Hi @douglasferraz89 and @reneesoffice

    Thanks for mentioning here. I’ve just tested Slim SEO with AMP and can’t replicate the bug. Please see this screen recording: https://www.loom.com/share/971f66d913eb4e8398b1be11c0ba5d38

    Thread Starter Douglas Ferraz

    (@douglasferraz89)

    Hi @rilwis

    I used a 150×150 image and the bug did not appear.

    I used images with a higher resolution and the problem mentioned persisted.

    I tested without other plugins, using only AMP and Slim SEO.

    Hi @douglasferraz89 ,

    I’ve tested again and found that with Slim SEO deactivated, the bug still happens with some image sizes.

    In my test, with only AMP plugin activated, lightbox still shows for large and full image sizes. It doesn’t show for thumbnail and medium sizes.

    Please see if you see the same issue. If so, then the bug is not because of Slim SEO (it actually doesn’t alter the content in any way).

    cc @reneesoffice

    Thread Starter Douglas Ferraz

    (@douglasferraz89)

    Hi @rilwis and @reneesoffice

    I tested using the following themes: Astra and Twenty Twenty and Twenty Twenty One.

    I used only two plugins: Slim SEO and AMP.

    I used high resolution images.

    With Slim SEO enabled, the problem happens.

    With Slim SEO disabled, the problem also happens.

    With Slim SEO enabled and disabling the Facebook Open Graph module, the problem does not happen.

    This is strange.

    Try to verify this.

    The AMP plugin has some problem when rendering the images, that’s a fact.

    Renee Johnson

    (@reneesoffice)

    @douglasferraz89 yes, I confirmed with you the open issue here:

    https://github.com/ampproject/amp-wp/issues/5122

    Please subscribe to the issue for updates on the progress. We’ll make a note to update you here when a fix is out.

    Plugin Author Weston Ruter

    (@westonruter)

    @douglasferraz89 Here’s a mini plugin you can activate which will prevent auto-lightboxes: https://gist.github.com/westonruter/b6691407af1648b402b09371a9faf7f0

    We’ll likely add the data-amp-auto-lightbox-disable attribute by default to the body in the next release.

    Thread Starter Douglas Ferraz

    (@douglasferraz89)

    @westonruter The problem was solved.

    cc @reneesoffice @rilwis

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Disable lightbox on images’ is closed to new replies.