Support » Plugin: Naked Social Share » Disable JavaScript no longer working?

  • Resolved Francesco

    (@fcolombo)


    Really sorry for being pedantic but I’ve just realised the small naked-social-share.min.js file is being loaded even when the Disable JavaScript option is selected. Am I doing something wrong?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author NoseGraze

    (@nosegraze)

    The follower numbers are now updated via ajax to stop the page load time from going way up when the numbers expire. The JavaScript file is now always included since I don’t have a non-JS fallback for that at this time.

    Though now that I think of it, I will make it so the file isn’t loaded if you have JS disabled and follower numbers disabled.

    Makes sense! Thanks for replying

    Plugin Author NoseGraze

    (@nosegraze)

    I’ve got that adjustment in place now but I’ll wait until tomorrow to release it in case any other support issues come in today.

    If you desperately want it adjusted now, you just need to tweak the nss_enqueue_assets() function (at the top) in includes/functions.php

    Right before the wp_register_script() function, add this in:

    if ( nss_get_option( 'disable_js' ) && nss_get_option( 'disable_counters' ) ) {
    	return;
    }

    Thanks! I’m in no rush at all. Feel free to roll out the update whenever you want 🙂 Thanks again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disable JavaScript no longer working?’ is closed to new replies.