Support » Plugin: WP Offload Media Lite for Amazon S3, DigitalOcean Spaces, and Google Cloud Storage » Disable https on amazonaws URLs containing period

  • If I turn on the “CloudFront or Custom Domain” option, and enter an S3 endpoint with a period in the bucketname (eg some.bucket.s3-website-us-east-1.amazonaws.com), the plugin converts the URLs to include an HTTPS eg https://some.bucket.s3‑website‑us‑east‑1.amazonaws.com/path/to/file . This also happens if I enter a custom domain that I have CNAMEd to the endpoint (this would force the bucket name to contain periods).

    The AWS doc mentions

    When using virtual hosted–style buckets with SSL, the SSL wild card certificate only matches buckets that do not contain periods. To work around this, use HTTP or write your own certificate verification logic.

    . So the URLs generated by the plugin fail and I am unable to view the media library within wp-admin.

    Is there a workaround to force http for such URLs? I do not intend to use Cloudfront.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I managed a workaround by using Cloudflare free and their flexible SSL for the subdomain. So now the HTTPS url works for wp-admin and visitors, while the connection between Cloudflare and S3 is unencrypted. However, it would be nice to have an option for HTTP in the plugin, for people who want to use the S3-provided endpoint instead of a subdomain.

    I’m having the opposite problem – we are moving to https and the plugin points to http: buckets. At the moment, we’d rather not use cloudfront. Is there a way around this to force https?

    Did you try the “Force HTTPS” option?

    Plugin Contributor ianmjones

    (@ianmjones)

    Funnily enough, using the Force HTTPS setting should help out in both cases as it’ll also switch the S3 URLs to use the bucket name in the path rather than the domain.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disable https on amazonaws URLs containing period’ is closed to new replies.