Support » Plugin: Posterno - Listings Directory & Classifieds » Disable Google Maps

  • Resolved dz9nr



    I am having a heck of a time disabling google maps from the submit listing page. I have followed the instructions from the documentation page on adding: add_theme_support( ‘posterno_disable_maps’ ); to the themes function.php page but the map still shows up. I do need members to put their locations in however (city and state) I just don’t want google maps to be involved. Please help. If I can get posterno to do what I need I’ll be purchasing several add ons.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Alessandro Tesoro


    Hi @dz9nr

    Apologies for late reply, I’m now back at work after the holidays.

    The code

    add_theme_support( 'posterno_disable_maps' );

    Does the following:

    – Disables the listing location widget
    – Disables the map from the single listing page
    – Disables the map from taxonomy pages
    – Disables the gmap scripts from single and taxonomy pages

    The only other places where the map would still show is the submission page on the frontend (this is a bug) and in the admin panel (this can’t be disabled right now).

    In order to remove the map from the location field on the listing submission page on the frontend, please add the following code to your theme’s functions.php file:

    add_filter( 'pno_get_option_map_provider', '__return_false' );
    add_action( 'wp_head', function() {
    	if ( is_page( pno_get_listing_submission_page_id() ) || is_page( pno_get_listing_editing_page_id() ) ) {
    			.pno-listing-submission-map {display:none;}
    } );

    The above code tells the plugin there’s no map provider enabled, because there’s no provider enabled, the plugin will automatically disable the gmap script from the submission page too. The css then completely hides the area where the map should have displayed.

    I’ll will release an update as soon as possible with a fix so that the code I provided is no longer required.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.