WordPress.org

Support

Support » Plugins and Hacks » Plugin Organizer » [Resolved] Disable front-end plugins from loading in admin area

[Resolved] Disable front-end plugins from loading in admin area

  • Hello,

    Thanks for creating a brilliant plugin, really does wonders for load time!

    I was wondering whether there was a function that would disable front-end plugins from loading in the admin area?

    Currently I’m running a site that has many plugins mainly geared towards front-end manipulation yet when I access pages in the backend (ie. /wp-admin/edit.php) **all** CSS, JS and plugin files are being loaded for plugins that are not required there, thus increasing the load-time and responsiveness of the admin area.

    I’m using wordpress 3.5.1.

    Thanks,
    Paul

    http://wordpress.org/extend/plugins/plugin-organizer/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeff Sterup

    @foomagoo

    Yes. On the settings page you can check the “Admin Areas” enable radio button under “Selective Plugin loading” and the plugins you have disabled globally will also be disabled in the admin area.

    You can also use the URL admin to only disable plugins on the admin. On the settings page select the enable radio button under “Fuzzy URL Matching” and also the “Admin Areas” enable radio button under “Selective Plugin loading”. Then in the URL Admin enter http://www.yoursite.com/wp-admin/ as a url and select the “Also effect children” checkbox. Then select the plugins you want disabled for the admin only. If you have plugins that are globally disabled and you want them enabled for the admin then just check them in the URL Admin under “Enabled Plugins”.

    hey Jeff!

    thanks for answering my question so quickly.

    I’ve gone through your suggestion by using URL admin to disable but unfortunately it’s not working. I’ve double checked all settings and all are set, also the admin URL is correct yet still unwanted plugins are loading in backend.

    Any chance you could have a look and possibly test your end? It seems it should work just just as it does on the front-end but for some reason it doesn’t.

    Thanks again for your support I really appreciate it!

    Paul

    Plugin Author Jeff Sterup

    @foomagoo

    Sorry. Make the url http://www.yoursite.com/wp-admin instead of http://www.yoursite.com/wp-admin/. I forgot you aren’t loading a permalink in the admin so it won’t end in a /.

    Jeff, I think I want to have your babies!

    Worked a charm, you’re such a legend! How can I send over some beer money for you??

    Plugin Author Jeff Sterup

    @foomagoo

    Woah! Calm down! Lol! No need to pay me and definitely no need to have my baby. LMAO!! Just promote the plugin if you get a chance and give it a rating on the plugin page.

    Hey Jeff,

    I’ve just given you a 5-star rating/review, also done a plugin review on my site to help promote the plugin further: http://www.livefreedietravelling.com/tech-web/plugin-organiser-speed-up-your-wordpress-website/

    Thanks again for developing such a great plugin.

    Regards,
    Paul

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Disable front-end plugins from loading in admin area’ is closed to new replies.
Skip to toolbar