Support » Plugin: Disable Gutenberg » Disable for Templates – Not working

  • Resolved tatof

    (@tatof)


    Hello,

    If I turn on “Disable for Templates” all my page templates get disabled.
    I turned off all other settings and only used this with:
    – page-home.php (file name)
    – page-home (file name)
    – Home (template name)

    None of these work and all the gutenberg pages are disabled.
    http://devtof.nl/screen.png

    Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Hi @tatof,

    Thanks for reporting. This looks like a bug. We will try to resolve it in the next plugin update. IN the meantime please let us know if you discover any further related infos. Thank you.

    Thread Starter tatof

    (@tatof)

    Thanks,
    Was testing Gutenberg + ACF and missed the “disable content wysiwyg” function of ACF.
    Thats why I installed this plugin and found out that disable for template doesn’t work.

    Its not a live site just a simple test server, thats all the info I’ve got

    Plugin Author Jeff Starr

    (@specialk)

    Thanks. I haven’t tested yet. Do you know if the reported issue happens when ACF is not active?

    Thread Starter tatof

    (@tatof)

    I can test that!
    How am I suppose to use this the function?
    Full file name? page-home.php

    Plugin Author Jeff Starr

    (@specialk)

    That could be the issue actually. Please try with both:

    – page-home
    – page-home.php

    It could be one or the other, and I forgot to document the correct syntax (sorry).

    Thread Starter tatof

    (@tatof)

    Before I allready tried both. But I found the solution!
    This is the problem:

    0. Open page with template (gutenberg)
    1. Change template to one without gutenberg
    2. SAVE
    3. Hard refresh (ctrl-shift-f5)
    4. Gutenberg is Gone!
    5. Change template back to one with gutenberg
    6. SAVE
    7. Hard refresh (ctrl-shift-f5)
    8. ??? gutenberg is not loaded..
    9. Go back to “all pages” and reopen the page.
    10. Gutenberg!

    So… gutenberg is nog loaded after a refresh or save

    • This reply was modified 1 year, 6 months ago by tatof.
    Thread Starter tatof

    (@tatof)

    ps. its “page-home.php”

    Plugin Author Jeff Starr

    (@specialk)

    Thank you @tatof! This is great infos, will use to help resolve the issue in the next plugin update. Will also add a note in the docs that page-home.php is the correct syntax.

    Thread Starter tatof

    (@tatof)

    No problem, ticket resolved.

    — waiting for plugin update —-

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up with this, the reported issue is resolved in the next version of DG. Should be available this next week or thereabouts. Thanks again for reporting, @tatof.

    heytricia

    (@tendigit)

    @specialk – I’m seeing the same or a similar issue. I set the plugin to disable only on a legacy template – using template-name.php.

    This worked to prevent g-blocks from showing in the edit view, but… it breaks layouts on the front end. Specifically, text and images set to center show the applicable classes in the DOM, but it looks like the styles to make that happen aren’t being served.

    Plugin Author Jeff Starr

    (@specialk)

    @tendigit, the issue should be resolved in the latest version of the plugin. So in order to help, I need clear steps to replicate the issue on default WP install. If you can provide, I will investigate further and try to resolve any issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Disable for Templates – Not working’ is closed to new replies.