Support » Plugin: Disable Gutenberg » Disable for templates not working anymore

  • Resolved Oikos

    (@oikos)


    Disabling by template doesn’t seem to be working anymore. Gutenberg is still defaulted regardless of the template selected.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Confirmed. Something must have changed. It’s now on the list and will try to resolve for the next plugin update. Thanks for reporting.

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up with this, after further investigation I can confirm that page template exclusions are working on default WP (tested on 5.5 beta). For it to work, the entire file name of the custom template must be added in the plugin settings. Here is the related infos from the plugin’s FAQs:

    In order for template exclusions to work, the template must be registered with the page itself. The only way to do this is via the “Edit Page” screen, in the “Page Attributes” meta box. There you will find an option to set the page template. Remember to save your changes.

    After assigning some templates, they will be recognized by Disable Gutenberg. So to disable Gutenberg on any registered template, you can add them via the plugin setting, “Disable for Templates”. Examples:

    • Template name is page-custom.php, located in the root theme directory: enter page-custom.php in the Template Exclusion setting
    • Template name is page-custom.php, located in a subdirectory named templates: enter templates/page-custom.php

    I hope this helps, let me know if I missed anything or can provide further infos, etc. Glad to help anytime.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.