Support » Plugin: iThemes Security (formerly Better WP Security) » 'Disable File Editor' doesn't work

  • Resolved kmcharityteam

    (@kmcharityteam)


    Hello,

    Even though ‘Disable File Editor’ is ticked, I am still able to use the file editor for plugins, themes etc.
    Unticking, saving, reticking, saving doesn’t work. Disabling and re-enabling the plugin doesn’t work. Disabling all the other plugins except this one doesn’t work.

    Anyone else experienced this?

    Thanks!

    https://wordpress.org/plugins/better-wp-security/

Viewing 2 replies - 1 through 2 (of 2 total)
  • It works fine over here using latest iTSec 4.6.8 release.

    Please make sure you have the following option in the “Global Settings” section ticked:

    Write to Files [x] Allow iThemes Security to write to wp-config.php and .htaccess.

    The “Disable File Editor” option needs to be able to add the following lines to the wp-config.php file:

    //The entry below were created by iThemes Security to disable the file editor
    define( ‘DISALLOW_FILE_EDIT’, true );

    If the above info helps you resolve the issue please mark this topic as ‘resolved’.

    dwinden

    Hi Dwinden,

    I am on latest 4.6.8 version too. I do have the option ticked and iTSec hasn’t complained that it’s not able to edit them. The Htaccess definitely accepts changes but I’m guessing it doesn’t like editing wp-config.php for some reason as that’s totally vanilla apart from the changes I’ve made myself to disable cron. I’ve added your line manually and now file editor is disabled 🙂

    Thanks for your help

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘'Disable File Editor' doesn't work’ is closed to new replies.