Support » Plugin: Phone Validator for WooCommerce » Disable error message for number not fitting to selected country

  • Resolved basvandijkk



    I was wondering whether I could disable the error message that is being shown upon selecting the country “Belgium” for instance and having an telephone number that is from “The Netherlands”.

    In our case someone can have a telephone number from “The Netherlands” and still have an address within “Belgium”. I saw that the error response was given through Javascript.

    How can I change this?

    • This topic was modified 4 years, 2 months ago by basvandijkk. Reason: Typo
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @basvandijkk , a user / customer can select the type of phone number they input
    For example, a user can select the country belgium, then for phone number field, they can change the country to Netherlands.
    The basic automation i did was because most people would have a number belonging to the same country, so for instance if a user selects billing country to Nigeria, the phone number field flag will change to Nigeria, but the user can always decide to change the country flag of the phone field to whatever country, hope this helps?

    Thread Starter basvandijkk


    Yeah I get what you mean, but as of right now I get a error message that the phone number does not belong to the user country. The country that is being selected within the checkout(so not the one for the prefix of the telephone number).

    Oh wow, that’s a bug
    Can you give me till tomorrow to give a temporary solution?
    I’ll send you what to adjust
    Hoping you can code

    hi @basvandijkk , i just did a test on my end, and the issue you stated does not occur to me
    my billing country was set to Nigeria
    while the phone number was set to Ghana
    and when i put in the correct Ghana phone format, there was no error generated.
    Although it is strange, have you tried debugging, deactivating all plugins except woocommerce and phone validator, and see if it works properly?
    Please i’ll love to hear a feedback from you 😃

    I’ll be marking this as resolved since no feedback 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Disable error message for number not fitting to selected country’ is closed to new replies.