Support » Plugin: Disable Emails » Disable Emails

  • Resolved nonuniverse



    I installed WordPress 6.0 yesterday. This error did not occur until this update. Now, when I send emails on my development site. I get a critical error. Since this is my development site, I’m not too worried, but I am worried about my staging site, where I use the same plugin. I did isolate the issue and it is definitely an error that only happens when Disable Emails is activated.

    Here is the error that is captured:

    [26-May-2022 06:24:14 UTC] PHP Fatal error:  Uncaught PHPMailer\PHPMailer\Exception: Invalid address:  (to):  in /home/urknownc/
    Stack trace:
    #0 /home/urknownc/ PHPMailer\PHPMailer\PHPMailer->addOrEnqueueAnAddress('to', '', '')
    #1 /home/urknownc/ PHPMailer\PHPMailer\PHPMailer->addAddress('', '')
    #2 /home/urknownc/ webaware\disable_emails\PHPMailerMock->_addTo('')
    #3 /home/urknownc/ webaware\disable_emails\PHPMailerMock->wpmail('', '', '<!DOCTYPE html>...', '', Array)
    #4 /home/urknownc/ wp_mail('', '', '<!DOCTYPE html>...', '')
    #5 /home/urknownc/ wp_update_user(Array)
    #6 /home/ in /home/urknownc/ on line 1092

    I would appreciate your assistance.
    Best Regards,
    NoN Universe Administrator

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author webaware


    G’day nonuniverse,

    Thanks for the report. It looks like it’s failing on an invalid email address, so I’ll add that to my testing and get a fix out. Can you tell me what the invalid email address might have been, or what it resembles if it’s private info?


    Plugin Author webaware


    Please update to version 1.8.1, just released. Thanks again for the bug report!


    Thread Starter nonuniverse


    Thank you for the fix. This is to confirm that your fix works. Bless you for the quick resolution.

    I have reported the missing email address situation to the BuddyBoss team. I hope that they are as quick as you are to resolve their side.

    Best Regards, Dianne

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Disable Emails’ is closed to new replies.