WordPress.org

Support

Support » How-To and Troubleshooting » Disable “edit” and User Page-

Disable “edit” and User Page-

  • cielogrande
    Member

    @cielogrande

    Hello- Is there anyway to completely disable the “edit” feature? I do not want authors to be able to edit their posts once they’re published.
    I would also like to make the “User” page unavailable because I don’t want members to have the ability to change their passwords. Are either of the above possible, and if so… how?
    Thanks, DB~

Viewing 8 replies - 1 through 8 (of 8 total)
  • groovyKimo
    Member

    @groovykimo

    Hi

    In the page templates (page.php is the basic one) look for something like
    <?php edit_post_link('Edit'); ?>

    This is calling the edit function.

    You may want to look for a “role manager” plugin also. I haven’t used it, but that gets mentioned a lot here in response to these type questions.

    Steve

    cielogrande
    Member

    @cielogrande

    groovyKimo-
    Thanks… I suppose I can just delete the code you mentioned. I’ll try it!
    Dennis~

    cielogrande
    Member

    @cielogrande

    Well… no luck deleting the “Edit” link. I think I searched through virtually all the pages for the code mentioned in the above response by groovyKimo and deleted what seemed to be the relevant code, but “Edit” still appears on the site.
    I wish there were such a thing as “WordPressLight…” a simplified version of WP without all the bells and whistles that just complicate the user experience for folks who want a straightforward, simple blog. Judging from all the Forum questions concerning the elimination/deactivation of various WP components, I get the impression that many frustrated users might find a Light version to be rather APPEALING, to say the least!
    Oh well…
    DB~

    groovyKimo
    Member

    @groovykimo

    Go to edit a page. There you can see on which template the page is build. Per default there are 3.

    The ‘default template’ shoud be ‘page.php’ in your theme directory. For disabling edit on pages (build on this template), this is the one.

    cielogrande
    Member

    @cielogrande

    groovyKimo-
    I’m pretty sure I already tried what you suggested in your last post, but I’ll try it again. Maybe I missed something?
    Thanks… DB~

    cielogrande
    Member

    @cielogrande

    SUCCESS!!! Thanks again groovyKimo— I must have made a silly error the first time around!
    DB~

    groovyKimo
    Member

    @groovykimo

    Welcome! 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Disable “edit” and User Page-’ is closed to new replies.