Support » Theme: Tiny Framework » Disable (custom) header only on attachment pages

  • Resolved elch93


    I love the theme and worked a lot on it using the great tips in the theme and as I am no expert the rest with trial and error. Works fine (not all, but the things that are important for me).
    But: one thing I don’t get fixed…. I have a gallery with images (just that simple thing wp offers). When I click on an image I come to the attachment page with this image. I managed it to show the image description, but: I have my custom (rotating) header at the top (as on all pages and sites) and below this my image. Looks a bit strange… On attachment pages I only want to see my images from the gallery (or other attachments), but not my custom header. How can I manage this? Would be great if it would be possible via style.css….
    Thank you!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • @elch93

    Please provide a link to your site


    It looks like this:

    The red one I want to disable – but only on attachments pages.

    Do you know how to manage this…?

    I looked at the theme demo and can’t see the issue you described please provide a link to your site

    As a guess try. If you don’t already have a Child_Themes or the theme offers nowhere to put a custom css, then you should install a plugin like Jetpack then add the following to the custom css area…

    .attachment .featured-image {
    display: none;

    Thanks for your help – it didn’t work, but inspired me to find the code that works:

    .attachment img.header-image {
    display: none;

    I used the Firefox > Web developer tools > Inspector to look for the name of that element (header).

    I’m so happy. Now that red thing (you see on my linked image) is gone!! But all the rest below is shown correctly.

    • This reply was modified 3 years, 1 month ago by elch93.
    • This reply was modified 3 years, 1 month ago by elch93.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disable (custom) header only on attachment pages’ is closed to new replies.