Support » Plugin: Jigoshop » Disable CSS for custom theme

  • Resolved Rick Bleakley

    (@rickblackdog)


    Hi, I’m a theme dev, just trying out Jigoshop2 on my localhost. Used to be an option to disable CSS, doesn’t seem to be in v2. Can you point me to the docs or new theming guide for v2?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jigoshop Support – Marcin

    (@azrielnefezen)

    Simply add
    Styles::remove([style_hook]);
    To your theme’s functions.php
    Hooks:
    jigoshop.shop – all shop pages
    jigoshop.user.account – all account pages

    Thread Starter Rick Bleakley

    (@rickblackdog)

    Sorry not having much joy here – tried this but not working?

    //REMOVE JIGOSHOP CSS
    
    add_action('wp_head','jigo_remove_action', 1);
    
    function jigo_remove_action() {
      remove_action('wp_head', 'jigoshop.shop');
    }
    
    remove_action('jigoshop.shop', 10);
    • This reply was modified 4 years, 4 months ago by Rick Bleakley.
    Flamekebab

    (@flamekebab)

    I’ve just performed the upgrade and I’m having the same problem. How do I disable JigoShop’s built-in CSS?

    Adding:
    Styles::remove([style_hook]);

    to the end of my theme’s functions.php just breaks the entire site:

    Fatal error: Uncaught Error: Class 'Styles' not found in /var/www/foxbox/wp-content/themes/easel/functions.php on line 427
    PHP7.1 screenshot

    Similarly I don’t understand what this part of the suggested solution means:

    Hooks:
    jigoshop.shop – all shop pages
    jigoshop.user.account – all account pages

    Did you solve the problem in the end @rickblackdog?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Disable CSS for custom theme’ is closed to new replies.