Support » Theme: Customizr » Disable Cropping

  • lilmisbelladonna

    (@lilmisbelladonna)


    Hi,
    I am trying to disable the cropping feature for the customizr theme. I want to be able to make an image a particular size and fits in that spot the exact way I made it. I have been struggling with the image problem for a while now and would love some help. The site I am working on is not live yet so I cannot send the link. Thank you in advance.
    Mary

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,
    I am in the same position and didn’t find a definitive solution but I did some testing and this is what I figured out.
    Firstly it may help to know the thumbnails sizes created by the theme.
    Try to upload a fresh new picture to wordpress media and in your ftp or local wordpress installation folder go to wp-content->uploads->current year folder (i.e. “2017”)->current month folder (i.e. “02”). There you will find the images you uploaded in that month. Look at the thumbnails names and you will find the exact size the images has been resized to by the current theme.
    Customizr by defaul creates images with the following sizes:
    http://docs.presscustomizr.com/article/36-image-sizes-in-the-customizr-theme

    In order to have full size images, in your customizr settings you have to set an image height corresponding exactly to the height of your original image.
    Just to make an example: if you want to show a featured post image of 870×580, just upload a picture of 870×580 and select an image height of 580px.
    Please refresh the page because what you see in live preview should not correspond to the actual result.

    In order to have a full size slider please follow carefully these directions and change the desired slider height accordingly to your needs (i.e. 700 px):
    http://docs.presscustomizr.com/article/217-how-to-set-the-sliders-height-in-the-customizr-wordpress-theme

    Remember to check the “Replace the default image slider’s height” check-box.
    Then upload an image of the exact image height you need (i.e. 1920x700px).
    This should make the image slider full size with no cropping.

    I still have issues with image responsiveness, especially in the slider.
    In particular I am not able to create @media queries for mid-sized screen (i.e. laptop) and somethimes the final result is ugly.

    i don’t know if there is some hidden setting I am missing for all these image size complaints I read here and there and I am sad to admit that under this point of view the developers are not to “supportive”….

    Hope this helps or at least can point you in the right direction.

    • This reply was modified 1 week, 4 days ago by  prenazol.
    • This reply was modified 1 week, 4 days ago by  prenazol.
    lilmisbelladonna

    (@lilmisbelladonna)

    Thank you. I will try the different sizes. I have it pretty close as of right now but it is very frustrating. Thank you for taking the time to answer.
    Gratefully,
    Mary

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.