Support » Theme: Hueman » Disable Creating Auto Resized Images

  • Hi there,

    I have a question about something I can’t figure out :).

    I’d like to disable the resized images that WordPress and/or the Hueman theme automatically creates. My site is very image heavy, and it uses a lot of space.

    – I went to Settings > Media and changed all settings to 0.

    – After that I went to the functions.php of the theme & child theme, but I couldn’t find any line containing add_image_size or set_post_thumbnail_size.

    – I added some code to functions.php to override the original code, but that didn’t work.

    I tried Googling and browsing the support forum, but I couldn’t find any other solutions.

    When I check the FTP still 8(!) images are auto generated with different sizes.

    Thanks in advance for taking out time in your day to help me :). Really appreciate it!

    Greets, Mariska

Viewing 4 replies - 1 through 4 (of 4 total)
  • I am having the same issue Mariska. Issue started when I upgraded to newest version of Hueman. It exploded many of my photos to the width of the screen. This is a real pain. I fix them. Regenerate and boom, they are exploded again.

    Hi @mariska88,

    If you remove the image sizes defined in the theme, it will affect the theme’s layout and design. This is not recommended.

    Thank you

    Thread Starter mariska88

    (@mariska88)

    Hi Denzel,

    Thanks for your reply. Our theme has been adjusted and tweaked so heavily over the course of 3 years, that we don’t use any of the themes defined image sizes.

    Only exception is the featured image, that we manually upload.

    So if you, or anyone reading this, knows of any way to disable this – I would really appreciate it if you share it :).

    Thanks, have a lovely day,

    Mariska

    This is what I use to disable ALL wordpress and Hueman theme image sizes, use at your own risk though because my theme is pretty heavily modified as well.

    1. WordPress Settings>Media
    Uncheck everything and set all to 0

    2. In functions.php (you may not want to use this, research it first)

    //Remove WordPress Responsive Images
    function disable_srcset( $sources ) {
    return false;}
    add_filter( 'wp_calculate_image_srcset', 'disable_srcset' );

    3. In functions.php

    //REMOVE WORDPRESS AND HUEMAN THEME THUMBNAIL SIZES
    add_action('init', 'remove_default_image_sizes');
    function remove_default_image_sizes() {
    remove_image_size('thumb-small');
    remove_image_size('thumb-standard');
    remove_image_size('thumb-medium');
    remove_image_size('thumb-large');
    }

    4. In functions.php I added this to specifically target the image sizes I want for my website, the largest size I use is 200×200 so I created all my images at 200×200 and THEN uploaded them to my site to save space. I’m sure you’ll need different sizes.

    //RELATED BEATS THUMBNAIL IMAGE SIZE
    if ( function_exists( 'add_image_size' ) ) {
    add_image_size( 'relatedbeats-thumb', 200, 135, array( 'center', 'top' ) );
    add_image_size( 'beatpost-thumb', 200, 200, false );
    add_image_size( 'thumbnail', 50, 50, false );
    }

    Once I did all I that I downloaded the Regenerate Thumbnails plugin and ran it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disable Creating Auto Resized Images’ is closed to new replies.