Support » Plugins and Hacks » [Resolved] Disable "Confirm Email Address"

[Resolved] Disable "Confirm Email Address"

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author megnicholas


    Hello Matthew,

    I’m afraid this is not possible without a lot of changes.
    I may well make ‘confirm email’ optional in a later release.

    You could possible add some hacks into css by hiding the confirm email input box and then filling it in automatically when the email address is entered using jquery/javascript, that way the form will validate on the server. Just thinking off the top of my head here!

    Sorry I can’t be of more help.


    I resolved the problem.
    In class.cscf_contact.php I changed following lines:
    if ($this->Email != $this->ConfirmEmail) $this->Errors['confirm-email'] = __('Sorry the email addresses do not match.','cleanandsimple');
    $this->Email != $this->ConfirmEmail;
    if (strlen($this->ConfirmEmail) == 0) $this->Errors['confirm-email'] = __('Please confirm your email address.','cleanandsimple');
    if (strlen($this->ConfirmEmail) < 0) $this->Errors['confirm-email'] = __('Please confirm your email address.','cleanandsimple');

    I tested it and it seems to work perfectly. The only problem I have is that every single email I send to my gmail goes straight to spam folder. Do you have resolution for that?


    Plugin Author megnicholas



    I’m sure you realise that you will have to make this change every time you update the plugin!

    Re the spam problem, try experimenting with the ‘Email Subject :’ and use some words that you don’t think are spammy.


    Yes, I realise that. Kind of sucks but that was the fastest method for me…

    I don’t think this would help. I tried many other plugins and there is exactly the same problem…

    Plugin Author megnicholas


    I use gmail also but don’t get the spam problem you are having.
    Are you ‘training’ gmail by clicking the ‘not spam’ button?

    Yes, I did that however it only worked for single email address.
    For example I used test@abc.com in my form. It was sent to spam solder and I clicked “This is not spam”. If I send more messages using contact form and the same address (test@abc.com) it worked. However when I used different email it went to spam again.

    I used WP Mail SMTP plugin (http://wordpress.org/plugins/wp-mail-smtp/) and it seems liek it fixed the issue.


    Just wanted to say thanks to neoh for the help in turning off the email confirm functionality.

    Love the HTML this plugin produces. I’ll take my chances with any upgrades.

    Ah, neoh‘s code changes didn’t quite work for me. My new solution is to alter a couple of line in two files. We hide the input box, then tell the form to compare the same email field.

    1. In /views/contact-form.view.php hide the confirm email address section using comment tags (<!– … –>) from line 45 to line 66.

    2. In line 33 of class.cscf_contact.php change

    $this->ConfirmEmail = filter_var($cscf['confirm-email'], FILTER_SANITIZE_EMAIL);


    $this->ConfirmEmail = filter_var($cscf['email'], FILTER_SANITIZE_EMAIL);

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Disable "Confirm Email Address"’ is closed to new replies.