WordPress.org

Forums

[resolved] [closed] Disable Comments for Page Option (37 posts)

  1. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Ladies and gentlemen of the WordPress development team,

    it's time the issue of disabling comments for pages is finally addressed. Pages are often more useful for business websites than posts, and comments at the bottom make business sites look too blog-like (that is, unprofessional).

    Unchecking the Comments checkbox in Screen Options in Pages or while editing an individual page does NOT remove comments.

    Only Quick Edit of the page actually allows to disable comments for the page.

    I find it really odd, and I'm not alone (see comments at the bottom of this tutorial)

    I think it would be most welcome improvement to WordPress is this issue is finally addressed.

    Best regards,

    Dimitri Vorontzov

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Unchecking the Comments checkbox in Screen Options in Pages or while editing an individual page does NOT remove comments.

    Yes it does - assuming you're using a decent theme. Why not simply edit page.php and remove the comment codes from there? Or create a no-comments custom page template?

  3. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    I am talking about Twenty Ten theme. It's supposed to be decent, isn't it, being WordPress official default theme? And yet for some reason the only way to disable comments on a page is through Quick Edit.

    I agree with your suggestions, Diva, they are great, but that wasn't the point of my post. Yes, I can totally recode the entire WordPress if I want to, but what I'm saying is, I shouldn't have to. I just wish the next version would eliminate the bug, that's all.

    Thank you for your suggestions!

    Best regards,

    Dimitri Vorontzov

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    You can disable comments on a per-page basis. On Edit Page, click Screen Options and ensure that the Discussion box is checked.

  5. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Thank you very much Esmi, but alas, what you're suggesting is exactly what doesn't work. That is why I wrote my post here in the first place.

    Do you think I would write this: "Unchecking the Comments checkbox in Screen Options in Pages or while editing an individual page does NOT remove comments." if I actually could disable comments the way you describe?

    That's the whole point, it doesn't work! Try it.

    Also, please see the comment made by Larry Leveen near the bottom of this page.

    In the most current version of WordPress, in Twenty Ten theme, the only way to disable comments for a page is through Quick Edit - because this option does NOT work in the normal edit – and I think this issue needs to be fixed in the next WordPress update. Perhaps, it should be called Twenty Eleven theme.

    Best regards,

    Dimitri Vorontzov

  6. peredur
    Member
    Posted 4 years ago #

    Dimitri is right - for me, at least. Unchecking the Comments checkbox doesn't work. In fact it was unchecked anyway when I looked. So I tried various combinations of checked and unchecked for 'Discussion' and 'Comments', but nothing worked. And I'm pretty sure I saved my changes each time. I certainly did for both options 'Off'.

    :-)

    I've been searching for an answer to this for hours. So in that respect I'm grateful to Dimitri for pointing out that it can be done from Quick Edit.

    Cheers

    Peredur

  7. This works fine for me on TwentyTen without any changes to anything. I tested turning comments on and off via the edit page feature and it works exactly right.

    Pages don't have comments.

    So :) Time to test your plugins!

  8. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    No plugins have been activated on my site so far, Ipstenu

    And it's not the only WordPress site where I experienced that issue. It's been a problem ever since they moved the comments option inside the sliding screen options tab.

    Ok, so turning off comments via the normal Edit works for some people and doesn't work for others. Isn't it time the issue is investigated and addressed?

    I mean, I probably should be just happy that I found the "Quick Edit" solution and relax, but if WordPress prides itself on being such an advanced framework, maybe fixing a bug would further improve its reputation among the business site owners.

    Just an idea.

    Best regards,

    Dimitri Vorontzov

  9. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    P.S. Now that I think about it, it would be nice to have a button or checkbox that would remove "Comments are closed" string, too, without digging into PHP.

  10. It's been a problem ever since they moved the comments option inside the sliding screen options tab.

    *blink* The what now? That should have had NO bearing on this at all. Also, it's ALWAYS been inside the screen options, it just used to be turned on by default and now isn't (unless you'd previously customized your page edit layout).

    To test, I changed mine to HIDE "Discussion" (which is the option that controls if you can see this or not). Made a new page. Comments are off. Un-hide Discussion. Comments remain off. Toggled on and off. No problems.

    If it works for some people and not others, then this is gonna be hell to reproduce and debug. Toss it up as a bug report on trac, but I suspect it'll be punted as 'works for me'.

    (Dissing WP because a bug FEW people are seeing wasn't fix is being a bit petty, by the way. If this was a huge bug seen by lots of people, it would be addressed. The odds are that this has to do with something on your server/browser more than JUST WordPress, and those are hellish to track down :/ Your personal help may be needed to create the error and show what's happening, so this will be a lot of work to debug, and you'll need to be involved.)

  11. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Nobody is "dissing" WordPress, dear Ipstenu. In fact, somebody (me) is trying to help WordPress to get even better than it is, and help others to find solutions to problems they may have encountered. That's what this forum is for, isn't it?

    And of course, if further help is needed, I would be eager to help. The WordPress team knows how to get in touch with me.

    I can see that you're passionate about WordPress, and that's a good thing. Those "few" people you are mentioning are still WordPress users, and user experience is what WordPress is supposed to be all about, correct? So any improvement, even a minor one, should be welcome.

    If you search Internet for "disable comments wordpress", you'll have a very clear idea of just how many people have a problem with it. Which means, the way it is now, is not intuitive, and needs improvement.

    One way or another, I think I made my point and I'm now leaving this discussion.

    Best regards,

    Dimitri Vorontzov

  12. peredur
    Member
    Posted 4 years ago #

    I can't help feeling that I must be missing something here.

    What if I do a virgin install of WP into another folder on my development box and then go through things step-by-step in response to suggestions?

    There's got to be a logical reason why the problem arises for some people but is absent for others.

    Any takers?

    Cheers

    PAE

  13. (edited to add: peredur - I DID make a fresh install of WP. No issues.)

    if WordPress prides itself on being such an advanced framework, maybe fixing a bug would further improve its reputation among the business site owners.

    That quote is ... well it struck me as sounding whiny and nitpicky and petty. It may not have been meant as such, and if so, I apologize. It just looks like you're saying WordPress prides itself on something it's not achieving which ... it is.

    Those "few" people you are mentioning are still WordPress users, and user experience is what WordPress is supposed to be all about, correct?

    Oh I agree, but my point stems more from over a decade of support work, and it's this: If a SMALL percentage of your user base has a weird problem you cannot reproduce, the likelihood is they did something really way out there without knowing it, and you will be in hell trying to solve it. And many times you will NOT be able to fix it because of how arcane the problem is.

    I did a quick skim of "disable comments wordpress" and I don't see your specific problem. I see what I expect to see. How do I turn off comments? How can I close comments on all my posts? How do I edit my theme to not say 'comments are closed'? etc etc.

    Unchecking the Comments checkbox in Screen Options in Pages or while editing an individual page does NOT remove comments.

    THAT issue I don't see. I can't reproduce it on a fresh, clean, install of WordPress (yes, I made one to test this).

    "Unchecking the Comments checkbox in Screen Options..." doesn't turn on/off comments. That just turns on if you SEE the discussion field in your page editor. Looks like this: Page editor 'Discussion Widget'

  14. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Wait a minute!

    Now we're getting somewhere!

    I know I pledged to leave the discussion for good, but Ipstenu wrote something important that drew my attention.

    So: the Discussion checkbox in screen options turns the Discussion Widget in the page editor on and off. That's why there is no way to edit comments in the normal Edit! Because the Discussion checkbox is unchecked by default!

    When the Discussion checkbox in the sliding panel is checked, the discussion widget appears at the lower part of the page editor and provides the option to disable the comments!

    Well, that makes sense. Whew!

    What doesn't make sense though is having WordPress installation come with the Discussion checkbox un-checked by default.

    Think of it: how in the world can a normal user figure out that there is a discussion widget that supposed to be there but isn't, if that widget is disabled by default and the checkbox that can enable it is hidden in a sliding panel that's virtually invisible unless you click a tiny tab that is also kinda hard to find? And how are people supposed to deduce intuitively this logical progression: click on the camouflaged gray on gray "Screen Options" tab to open the hidden sliding panel, and check the Discussion checkbox to enable the hidden Discussion widget, and then uncheck the Comments checkbox in the discussion widget to hide the comments?

    It's just not intuitive. I suggest that in one of the future versions of WordPress it should be re-done in a way that it's immediately obvious, because more and more people are using WordPress as a non-blogging platform, and they all need to turn off comments easily, without spending ours searching Internet discussion forums for the answer. Ditto "Comments are closed" thing.

    The best way to do it, is to make sure that the Discussion checkbox is checked by default, the way it used to be in the older versions.

    I just installed the new WordPress, simply to double-check, and guess what? The Discussion widget is indeed disabled by default.

    I suspect maybe it's not the case with some of the installations, even though I have no idea how that can be. It seems that maybe some people get the new WordPress with Discussion checkbox checked, and others get it with the Discussion checkbox unchecked. Those who get it unchecked, can't find it because it requires too many steps, and all the steps are hidden somewhere.

    Or maybe it's just that some people who have years of WordPress development and support experience behind their belt (like our mutual friend Ipstenu) know about the secret, "easter egg" style Discussion widget hidden inside another "easter egg" hidden panel, and that explains why they can't reproduce the issues. They just open and click the Discussion checkbox without giving it a second thought. Well, I think it's best if a user can do it without having those years of experience.

    THAT is the issue that I think should be corrected.

    Best regards,

    Dimitri Vorontzov

  15. What doesn't make sense though is having WordPress installation come with the Discussion checkbox un-checked by default.

    [...]

    THAT is the issue that I think should be corrected.

    Now that I understand what you were (rightly!) losing your mind over, on THAT we both can agree :)

    I'd add in a way to turn comments off JUST for pages would be nice too, but that's really something you can do in a theme. If you don't want comments on pages, you just remove the 'comment' section from the page.php file.

  16. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Glad we came to an actionable conclusion about this, Ipstenu.

    Until you posted that link to the Discussion widget image, there was no way for me to know that the Discussion widget even existed in WordPress 3. I really thought that it has been deprecated or left out for some weird reason, because all my WordPress 3 installations came "as if without it".

    Now I understand what's going on and I hope this thread helps other (probably few ;-) people like me who were struggling with the same issue and felt forced to create custom page templates to remove comments (not that there's anything wrong with adding custom page templates).

    It's a minor thing, but fixing it would make the overall WordPress experience so much better.

    How can this be escalated to reach the people who make decisions about what improvements to include to the next version of WordPress?

    Best regards,

    Dimitri Vorontzov

  17. Normally it gets posted to trac.wordpress.org - I was about to do that and then I decided to ask a couple folks WHY it was moved. If I find anything useful, I'll let you know.

  18. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Thanks, would be grateful for that Ipstenu. Now that I invested so much energy into determining the true nature of the problem, I feel kinda attached to the outcome. :-)

  19. Okay, quick answer - Since 3.2 JUST went into Beta, it's probably not going to get picked up as it's not really a bug. Semantics in that one. AFTER 3.2 comes out, it's more likely to get traction with the developers, even though this is a pretty quick fix, unless someone gets a wild hair up their shorts.

    I'm mentioning it to a couple devs, see where that goes. If it doesn't get picked up then, I'll try to remember to toss it in trac after 3.2 drops this summer (making a note on my calendar now for July 4th).

  20. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Cool! Thanks!

    Hope to hear from you again after July 4th or whenever.

    Best regards,

    Dimitri Vorontzov

  21. timlindop
    Member
    Posted 4 years ago #

    Hi,

    I just discovered this discussion after having spent countless hours trying to turn off the comment box (hide it) with no success. I am glad to see you came to a resolution after a few exchanges that seemed to border on nastiness. I bet you if there were a show of hands you would find that there are many, not just a minority of users, who can't make this work. One thing though, could someone walk me through the process that is agreed upon as the solution? I did not see a discussion plug-in or widget that need deactivation when I went to those links on my page. So please help, I know I am missing something.

    Tim

  22. timlindop
    Member
    Posted 4 years ago #

    I should also add I can't find the slide panel where the widget is hidden. Thanks.

    Tim

  23. I think we were both just being really passionate ;) It happens.

    The slide panel: It's up at the top of your 'edit page' in the light grey bar.

    Looks like this expanded:
    http://4rapiddev.com/wp-content/uploads/2011/03/Wordpress-Screen-Options.jpg

  24. Dion Hulse
    Lead Developer
    Posted 4 years ago #

    For reference, Here's where they were hidden by default in WordPress 3.1: http://core.trac.wordpress.org/ticket/14212

  25. timlindop
    Member
    Posted 4 years ago #

    I got it! My silly error. I was assuming that the screen options was for the page, itself, not for what appeared on the editing screen. Beat myself on the head over that one for a long time. Thanks for your help!

    Tim

  26. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    I've just realized that even though the matter had been more or less clarified, the discussion still doesn't actually include the complete, clear and precise instructions on how to disable comments for pages in WordPress version 3.1 (as well as probably also in 3.0 and at least some of the later versions).

    I think adding these instructions would be helpful to people who discovered this discussion online, so let me post them here:

    1. Click Pages on the vertical menu located near the left side of the Admin panel. A submenu will open, revealing two submenu items: Pages and Add New. The Pages admin page will also open.

    2. Click the title of the page you want to disable comments on – or hover over that title and select the Edit option below it. The Page Editor will open.

    3. At the upper right corner of the page editor, right below the greeting "Howdy,", click Screen Options tab. The hidden panel Show on Screen will slide open, containing a certain number of checkboxes and radio buttons.

    4. Place a check mark in the Discussion checkbox.

    5. Click again the Screen Options tab to slide hidden the Show on Screen panel. (this step is optional, if you'd like to keep the Show on Screen panel open, it won't in any way interfere with the next step.)

    6. Scroll down to the bottom of the Page Editor, to see the Discussion Widget that magically appeared where it wasn't before.

    7. Deselect "Allow comments" and "Allow trackbacks and pingbacks" checkboxes.

    8. Click Update button.

    Et voila, you've just disabled the comments on that page!

    Alternatively, you can also do this:

    1. Click Pages on the vertical menu located near the left side of the Admin panel. A submenu will open, revealing two submenu items: Pages and Add New. The Pages admin page will also open.

    2. Hover over the title of the page you want to disable comments on, and select Quick Edit option below it. The Quick Edit page opens.

    3. Deselect Allow comments checkbox.

    4. Click Update button.

    Same results, the comments for that page have been disabled.

    I may be wrong, but it looks like WordPress currently (version 3.1) doesn't come with the one-click option of automatically disabling comments for all the pages at once. That kinda sucks, because I can imagine how that option may be time-saving for people who use many pages and are forced to edit every single one to disable comments.

    Perhaps this issue should be addressed, too.

    Hope you find this post helpful.

    Best regards,

    Dimitri Vorontzov

    * * *

    P.S. I was pleased to find Dion Hulse's post above. It feels oddly gratifying to know the exact people to thank:

    http://profiles.wordpress.org/users/nacin

    Thank you Andrew for coming up with the idea of making the Discussion Widget invisible by default! Because of your creative initiative, I spent lots of hours making custom page templates, and became a lot better at this whole WordPress thing. I'm not being ironic. I mean it.

    http://profiles.wordpress.org/users/Viper007Bond

    Thank you Alex for supporting Andrew's idea! :-)

  27. I may be wrong, but it looks like WordPress currently (version 3.1) doesn't come with the one-click option of automatically disabling comments for all the pages at once.

    WordPress in and of itself has two settings:
    1) All comments on.
    2) All comments off.

    (Remember when I said you sounded whiny and nitpicky and petty? That remark to Nacin is a great example of something that looks, to me, like you're pretty much attacking him. Which I suspect is not the case, but if I saw that aimed at me, I'd think you to be kind of a jerk. The internet is hard to see tone :/ )

    Anyway. You'll note Viper said he did agree, just not for revisions. So ... it should probably be broken out into separate boxes listed for pages as for posts.

  28. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Nope, not trying to attack anyone, just poking fun. No need to read malicious intentions into my innocent posts. I'm sure Andrew and Alex will be able to see I'm being friendly, if they ever bother to visit this forum at all.

    I do admit I enjoy playing a jerk every now and then though: it expands my overall human range. Maybe you should try it sometime Ipstenu, you may like it better than just being a nice person all the time.

    Anyway, to prevent further attempts at flame wars, let's stick to business. I have two questions pertinent to the main topic of this discussion:

    1) How does one actually turn on and off all WordPress comments site-wide (step-by-step instructions would be welcome)?

    2) How can one keep the comments turned on for blog posts, but disable them for all the pages with one click?

    Best regards,

    Dimitri Vorontzov

  29. 1) How does one actually turn on and off all WordPress comments site-wide (step-by-step instructions would be welcome)?

    For future comments, Dashboard > Settings > Discussion. Check "Allow people to post comments on new articles"

    For all existing posts, however, it's an SQL thing:

    UPDATE wp_posts
    SET comment_status = 'closed', ping_status = 'closed';

    2) How can one keep the comments turned on for blog posts, but disable them for all the pages with one click?

    You don't. It's SQL/Database stuff.

    I wrote a post about the various options: http://code.ipstenu.org/2011/wordpress-open-comments-more-selectively/

  30. Dimitri Vorontzov
    Member
    Posted 4 years ago #

    Thank you Ipstenu – ;-) – this is most helpful, and is also a valid and reasonable way to promote your personal website. I mean it as a sincere praise. I'm not making fun of you. I had to add this just in case, to make sure you interpret my words correctly.

    But wouldn't it be cool to have at least some of these things accessible as a one-click option as a part of WordPress functionality?

    More specifically, I'm sure lots of people would be happy if they could:

    a) Just deselect a checkbox and disable the comments for ALL the pages, without editing every single one of them. Some non-blog WordPress websites may have hundreds of pages, and it would save lots of time not to have to disable the checkbox individually for each page. At the same time, I'm sure some users would want to include a blog in their otherwise non-blog website, and for the blog posts they would probably want to keep the comments enabled.

    b) If necessary, disable comments for all existing posts, too, at one click. Let's say, someone has hundreds of blog posts and upon redesigning the website decides that the comments to old posts are no longer necessary. Let's say that person wants to keep the comments just in case, but wants them not to be displayed. It would be great to just deselect a checkbox and – presto! - all the old comments are hidden.

    I am suggesting these things for being included in the future versions of WordPress, too. Unfortunately I don't have the privilege of being acquainted with any of the WordPress development team members, but would be grateful if my suggestions somehow reach the decision-makers!

    Best regards,

    Dimitri Vorontzov

Topic Closed

This topic has been closed to new replies.

About this Topic