Support » Plugin: Contact Form 7 » Disable chrome auto complete

  • Resolved mountier

    (@mountier)



    I am trying to stop the Chrome auto complete feature working on a form but without success. I see in the latest changelog that there is a reference to autocomplete being an option but I cannot see where this is located. Is it possible to stop the auto complete function in the browser via the code

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Yes, you can use the autocomplete option for that like this:

    [text your-name autocomplete:off]

    mountier

    (@mountier)

    Fantastic, thank you

    Hi Takayuki,

    I am using conditional fields in a form. There are 2 conditions and in both, the name is required, however I needed to give this field a unique name in each condition Eg:

    condition1-your-name
    condition2-your-name

    I tried to use “your-name” in both conditions but this caused problems as some of the email confirmations just showed a blank value

    Therefore in the confirmation email I have:

    Dear [condition1-your-name][condition2-your-name],

    etc..

    Only the actual populated field is shown

    The problem is though that with auto complete in Chrome, it will actually fill in BOTH fields, even though one is hidden, and then the email confirmation looks bad, for example if Bob Jones filled in the form it looks like:

    Dear Bob JonesBob Jones,

    etc.

    I have disabled autcomplete as suggested, but this is not honoured in Chrome (though works in Firefox)

    Do you have any suggestions as how I can avoid this?

    Thankyou.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Disable chrome auto complete’ is closed to new replies.