Support » Plugin: amr ical events lists » Disable Cache

  • Is it possible to disable cache in the amr ical events lists plugin? I’ve tried adding ?nocache=true and &nocache=true to the urls I’m pulling ics files from and the list still doesn’t refresh. I’d be fine with just disabling cache for the entire plugin if that is possible. Any help you can offer would be great. Here is the current shortcode being used on the page.

    [iCal https://wesleywillows.org/calendar/category/peterson-meadows/?ical=1&tribe_display=custom&nocache=true https://wesleywillows.org/calendar/category/wesley-willows-castle-town-center/?ical=1&tribe_display=custom&nocache=true https://wesleywillows.org/calendar/category/wesley-willows-fitness/?ical=1&tribe_display=custom&nocache=true https://wesleywillows.org/calendar/category/willows-arbor/?ical=1&tribe_display=custom&nocache=true listtype=12 grouping=day show_month_nav=1 calendar_properties=0 months=1 events=400 pagination=0]

    • This topic was modified 8 months, 1 week ago by aaronbiby.
    • This topic was modified 8 months, 1 week ago by aaronbiby.
    • This topic was modified 8 months, 1 week ago by aaronbiby.
    • This topic was modified 8 months, 1 week ago by aaronbiby.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author anmari

    (@anmari)

    Looking at my notes https://icalevents.com/support/documentation/shortcodes/#parameters, It says those only work in ics=url in a query url for testing purposes. Don’t remember why.

    In beginning there were problems with remotes sites ics fetches timing out, so the plugin always makes a local copy when it fetches the ics file, so it at least has the most recent successful fetch to work with.
    https://icalevents.com/4029-external-ics-files-timing-out/
    One can also set the cache period lower. Honestly I can’t remember if one can set it to 0 hrs. Or whether 0.1hrs – I’m not at my desk right now, you could try.

    If you need to maintain events more real-time than that , consider using amr-events rather.

    Note that also when plugin First started, some external ics providers did not update the ics real-time. So even when one has updated an event and ‘refreshed’ it was not in the file. Haven’t heard that lately, but good idea to actually download and open in a text editor to check whether newest event is there.

    I’m just running the amr ical events lists plugin right now, not the full blown amr-events plugin. I didn’t see where to set the cache period like you have outlined in the mentioned articles. Do I need the premium amr-events plugin in order to see that option? Also I did check the file in the url to make sure the recently published events exist in the feed.
    Thanks,
    Aaron

    Plugin Author anmari

    (@anmari)

    It’s per littype

    See settings in menu: ical-events-list > listypes > configure a listype
    click on ‘maximums’ – see the field labelled ‘cache’ as per https://icalevents.com/1814-refresh-calendar-if-new-dates-not-showing/

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Disable Cache’ is closed to new replies.