WordPress.org

Forums

Manual Related Posts
[resolved] Disable Cache (8 posts)

  1. remedix
    Member
    Posted 2 years ago #

    Hello there,
    Great plugin! Thanks!

    Is there a way to disable cache completely ? It's messing things up!
    Thanks

    http://wordpress.org/extend/plugins/baw-manual-related-posts/

  2. Julio Potier
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, update the last version 1.7.12 ;)

  3. remedix
    Member
    Posted 2 years ago #

    Great thanks!
    Now let's just say I just want to receive an array with $post objects. Can I do that with any of your filters ?

  4. Julio Potier
    Member
    Plugin Author

    Posted 2 years ago #

    No, what's the goal ?

  5. remedix
    Member
    Posted 2 years ago #

    To customise the results exactly as I want them without having to worry about replacing your tags.

    For example I might want to create list of 'div' elements or even customise the html of the output.

    Your filter 'bawmrp_posts_content' only gets the html content right ? One parameter right ?

    Maybe I'm missing something.

  6. Julio Potier
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, this is not implemented i admit, let me add this asap so!

  7. Julio Potier
    Member
    Plugin Author

    Posted 2 years ago #

    Ok i added a function named "bawmrp_get_all_related_posts" and you can use it like that:
    $related_posts = bawmrp_get_all_related_posts( $post );
    In a loop or single post where $post is the actual post, the result (in $related_posts) will contains all posts objects.
    Is it ok ?
    See you

  8. Barbara Muerdter
    Member
    Posted 2 years ago #

    This was helpful for showing the manually picked related posts properly. But it shows the most recent articles under most posts if I didn't chose any manually (funny enough I found a few exceptions, where it automatically shows different posts). I started the blog more than four years ago an it has more than a thousand articles and a good dozend categories. That seems very odd. Otherwise everything works fine and looks great.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Manual Related Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.