Support » Plugin: WooCommerce » Disable auto scroll to top

  • Resolved cl0ne



    I’m trying to disable a feature in Woocommerce that I believe is related to Woocommerce itself and not specific plugin or theme. I’ve seen this discussed elsewhere but no clear solution has surfaced.

    When you add a product to cart in woocommerce, it auto scrolls to the top that shows a message that the product has been added.

    I personally find the behavior annoying and I’m trying to find out how I can turn it off.

    I don’t have an issue with the message, though I would like to re-position it if possible.

    Any guidance would be appreciated.

    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Does it reload the page or just auto-scroll? If the latter, it is your theme design. The first happens when the theme does not support ajax (or something breaks it). Most ajaxified themes add products to cart without moving the screen position.

    Hey superkot!

    Thanks for that information. I’m using a child theme of Woocommerce Storefront theme. I assume that this behavior is Storefront related then. Is that correct?

    Thanks again.

    I’ve checked my Storefront-based site and it does not mess with screen position when you add to cart from the shop (if you have ajax enabled in Woo settings), but does reload the page when product is added from the product’s page – no ajax there.

    I see.

    Then I have a feeling this is caused by the plugin “One Page Checkout” by Woocommerce.

    I guess I may have to contact them regarding how to turn of this feature.

    Thanks for your help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disable auto scroll to top’ is closed to new replies.