• our client is requesting an option to disable auto open. It would be nice to control the auto open on a content-type basis. IE: auto open on the this post-type only or auto open on homepage only.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m looking a solution on this as well.

    Found the solution, just add “greeting_dialog_display=’hide'” in the script.

    I am a novice and I need a little more direction. Where exactly do I put the script you provided to auto hide the messenger display?

    @batman8702 In the backend, you will see this code in the plugin settings. notice the last line of code.

    <div id=’fb-root’></div>
    <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    js = d.createElement(s); js.id = id;
    js.src = ‘https://connect.facebook.net/en_US/sdk/xfbml.customerchat.js#xfbml=1&version=v2.12&autoLogAppEvents=1&#8217;;
    fjs.parentNode.insertBefore(js, fjs);
    }(document, ‘script’, ‘facebook-jssdk’));</script>
    <div class=’fb-customerchat’
    attribution=”wordpress”
    page_id=’xxxxxx876987623′
    greeting_dialog_display=”hide”
    >
    </div>

    Thank you for the response. I put the greeting_dialog_gisplay=”hide” right under the page_id=***** but there was no change. I am sure that this is me missing something but I am not sure what. My goal is to achieve this: once a user opens my site and choose to close the chat greeting bubble, I want the greeting bubble to stay closed instead of opening every time a page is refreshed of=r changed. Any clues on what I may be doing wrong?

    Clear your browser cache or check in incognito mode.

    Try this:

    greeting_dialog_display='hide'

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘disable auto open’ is closed to new replies.