• Resolved mattspaur

    (@mattspaur)


    In Settings > Admin, I have turned ON the option “Disable analytics under posts/pages (wp-admin).

    When I look in my Dashboard list of top pages by views, I see the following pages:

    https://equipourkids.org/wp-admin/
    https://equipourkids.org/wp-admin/edit.php
    https://equipourkids.org/wp-admin/post.php?post=16626&action=edit
    https://equipourkids.org/wp-admin/edit.php?post_type=page
    https://equipourkids.org/wp-admin/admin.php?page=analytify-dashboard
    https://equipourkids.org/wp-admin/options-general.php?page=insert-headers-and-footers

    I thought that all these would be excluded because I had turned on the option in Settings. Can you please tell me what’s going on here?

    I think this is hurting our average time on site stat. In the trailing four weeks, of our top 40 pages, the clear majority of them have average times ranging from one minute to 6.5 minutes, but our average time on page stat is only 38 seconds.

    I’ve included our system log below:

    ++++++++++++++++++++++++++++++++++

    -- System Information --
     
    site_url(): https://equipourkids.org
    home_url(): https://equipourkids.org
    WordPress: 5.8.2
    Web Server: Apache
    PHP: 7.4.26
    MySQL: 5.7.32-35-log
    ext/mysqli: yes
    WP Memory Limit: 128M
    Blocked External HTTP Requests: None
    WP Locale: en_US
    DB Charset: utf8mb4
    Debug Mode: No
    WP Max Upload Size: 256 MB
    PHP Time Limit: 120
    PHP Error Log: php_errorlog
    fsockopen: Enabled
    OpenSSL: OpenSSL 1.1.1l FIPS  24 Aug 2021
    cURL: Enabled (7.66.0 OpenSSL/1.1.1l-fips)
    Active Theme Name: Phlox Child
    Active Theme Folder: phlox-child
    Parent Theme Folder: phlox
    
    -- Active Plugins --
     
    Phlox Core Elements (v2.8.9) by averta
    Phlox Portfolio (v2.2.2) by averta
    Better Search Replace (v1.3.4) by Delicious Brains
    Classic Editor (v1.6.2) by WordPress Contributors
    Duplicate Page (v4.4.6) by mndpsingh287
    Elementor Pro (v3.4.1) by Elementor.com
    Elementor (v3.4.8) by Elementor.com
    GA Google Analytics (v20210719) by Jeff Starr
    GTranslate (v2.9.6) by Translate AI Multilingual Solutions
    Health Check & Troubleshooting (v1.4.5) by The WordPress.org community
    Insert Headers and Footers (v1.6.0) by WPBeginner
    MC4WP: Mailchimp for WordPress (v4.8.6) by ibericode
    Plugin Notes Plus (v1.2.5) by Jamie Bergen
    Redirection (v5.1.3) by John Godley
    Stop Spammers (v2021.20) by Trumani
    WooCommerce (v5.9.0) by Automattic
    Yoast SEO (v17.7.1) by Team Yoast
    Analytify - Google Analytics Dashboard (v4.1.5) by Analytify
    Smush (v3.9.2) by WPMU DEV
    WP-Sweep (v1.1.5) by Lester 'GaMerZ' Chan
    
    -- Must-use Plugins --
     
    Health Check Troubleshooting Mode (v1.7.1) by 
    
    -- Analytify Profile Setting --
     
    install_ga_code: off
    exclude_users_tracking:
    Array
    (
        [0] => administrator
    )
    
    profile_for_posts: 198548040
    profile_for_dashboard: 198548040
    hide_profiles_list: off
    
    -- Analytify Front Setting --
     
    
    -- Analytify Admin Setting --
     
    disable_back_end: on
    show_analytics_roles_back_end:
    Array
    (
        [0] => administrator
        [1] => editor
    )
    
    show_analytics_post_types_back_end:
    Array
    (
        [0] => post
        [1] => page
    )
    
    show_panels_back_end:
    Array
    (
        [0] => show-overall-dashboard
        [1] => show-geographic-dashboard
        [2] => show-system-stats
        [3] => show-keywords-dashboard
        [4] => show-social-dashboard
        [5] => show-referrer-dashboard
    )
    
    exclude_pages_back_end: 16626
    
    -- Analytify Dashboard Setting --
     
    show_analytics_panels_dashboard:
    Array
    (
        [0] => show-real-time
        [1] => show-compare-stats
        [2] => show-overall-dashboard
        [3] => show-top-pages-dashboard
        [4] => show-geographic-dashboard
        [5] => show-system-stats
        [6] => show-keywords-dashboard
        [7] => show-social-dashboard
        [8] => show-referrer-dashboard
        [9] => show-page-stats-dashboard
    )
    
    show_analytics_roles_dashboard:
    Array
    (
        [0] => administrator
    )
    
    -- Analytify Email Setting --
     
    
    -- Analytify Advance Setting --
     
    gtag_tracking_mode: gtag
    user_advanced_keys: off
    client_id: 707435375568-9lria1uirhitcit2bhfg0rgbi19smjhg.apps.googleusercontent.com
    client_secret: Hidden
    redirect_uri: 
    anonymize_ip: off
    force_ssl: off
    track_user_id: off
    depth_percentage: off
    demographic_interest_tracking: off
    404_page_track: off
    javascript_error_track: off
    ajax_error_track: off
    linker_cross_domain_tracking: off
    linked_domain: 
    custom_js_code:
Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi @mattspaur

    The “Disable analytics under posts/pages” option disables the Analytify meta box in single post edit screen, it will not exclude post from being tracked.

    Analytify tracks all pages of post type selected in “Enable analytics on post types” option in Front tab of Analytify settings.

    However, to exclude pages from analytics report add the post id in “Exclude analytics on specific pages” in settings page.

    Screenshot: https://monosnap.com/file/wP5IvNvdhYJfdBpH3DCdxnyNjVE6Q9

    Note this will only exclude stats from dashboard, not from being tracked.

    Thread Starter mattspaur

    (@mattspaur)

    There are admin pages that you are trying to exclude.

    They are not tracked with Analytify by default. Please make sure you have disabled admin tracking by adding “Administrator” in “Exclude users from tracking” settings.

    Screenshot: https://monosnap.com/file/yy7Gn1ldOEfhQtxbNYy4k7OcyPflKF

    Do make sure that you are using the tracking code option from Analytify settings (https://monosnap.com/file/WpkOA0u9k0KbFa82QK8684b5hKv25p) and NOT adding tracking code from theme or any other plugin.

    • This reply was modified 2 years, 7 months ago by Asad Shahbaz.
    Thread Starter mattspaur

    (@mattspaur)

    I do have Administrator included in the Exclude users from tracking setting.

    I did not have the tracking code option turned on previously. I’ve turned it on now. We’ll see what impact that has. Thanks for your help.

    Thread Starter mattspaur

    (@mattspaur)

    Hi–I’ve turned on the tracking code option, obtained the tracking code from Google Analytics, and pasted it into the header section of my website using the Insert Headers and Footers plug-in. Now, I get a message that says, “Analytify Dashboard can’t be loaded until you select your website profile.” When I try to select a profile in Analytify settings, there are no profiles in the list. Can you help?

    Let me clarify some things.

    Your diagnostic log shows that you have the “Install Google Analytics tracking code” option turned-off, so Analytify is not tracking anything at all. Even when that option is enabled, Analytify does not tracks the wp-admin/* links.

    You most have the Google Analytics code installed on both the front-end and the wp-admin of your site. That is why you can see the wp-admin* pages listed on your Analytify Dashboard. I recommend you check the “Header & Footer” plugin.

    Remove the tracking code you are manually installing, Analytify will handle that (just turn on the “Install Google Analytics tracking code” option from settings).

    If you are unable to see your profiles in the settings, try to logout and re-authenticate. If profiles still don’t show-up, please contact us on our support from: https://analytify.io/support/

    Thread Starter mattspaur

    (@mattspaur)

    Thanks for your help–I now have removed the tracking code that was inserted manually, turned on Install Google Analytics tracking code, and logged out and back in. I can now see profiles in Analytify Settings and pick the one I need.

    I still see an average time on site of 34 seconds for the last 30 days, which doesn’t seem to make sense mathematically. In that time, we have 9,151 page views. 7,403 of those page views come from our top five pages, and all those pages show an average time on page between 1:34 and 5:33.

    If 80 percent of our page views have an average time on page greater than 90 seconds, it seems unlikely that 100 percent of our page views have an average time on page of 34 seconds. (Mathematically, if I have 80 items with an average of 90 seconds and 20 items with an average of 1 second, then the average of those 100 items is ~71 seconds.) Can you confirm that this average time on site is an artifact of the previous incorrect configuration?

    I also still see /wp-admin listed in our top ten pages, and other /wp-admin/* pages in our top forty pages. That might also be an artifact of the previous incorrect configuration. Can you confirm that?

    Analytify does not calculates stats, we pull this information directly from Google.

    The Avg. time on site on Analytify’s Dashboard is Avg. Session Duration on Google Analytics for the entire site.

    You can check the Avg. time on Page by editing the page and checking the stats under “Analytify – Stats of this Post/Page”. This will show Average time spend on a specific page.

    Incorrect installation of the tracking code caused the Avg. time on site to drop significantly. It is also responsible for /wp-admin/* pages showing under top pages as they should not have been tracked.

    Now that you have removed the manually installed code and are using the tracking code option Analytify provides, your future reporting will be accurate.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Disable analytics under posts/pages not working’ is closed to new replies.