Support » Fixing WordPress » Directory Problem

  • People go to my site by going to http:/www/
    My WP directory is located at http:/www/

    When people go to http:/www/ most of my site appears, but not everything. If they go to http:/www/ everyhting in my site appears correctly. However, at other times the http:/www/ does show everything. It seems to be incosistent when the home page displays correctly.

    What should I do so that when they go to my site it directs them to http:/www/ thereby allowing my users to consistently see everything displayed correctly on my home page ?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Put this in the root .htaccess:
    Redirect /olddirectory/oldfile.html
    Put it all on one line, though

    I use Yahoo as my web host provider and they do not allow access to the .htacess file. Below is my root index file (http:/www/myfamilywebsite/index.php). Do I need to fix anything here ?
    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);
    define(‘WP_IN_ROOTDIR’, true);

    Ok, I may be confused.
    Your wordpress directory is here:
    but your theme’s index.php is here:
    Are you running some sort of static page? Or?
    I keep getting redirected to yahoo on both links.

    The site is When prompted for the id and password put temp for the id and temp for the password. You will be prompted twice (may be related to my problem above).

    See how it goes from to

    Please help.

    Thanks for the link, but can you tell me what a normal install of wp look like in terms of the wp directory. Is it done like the above link describes. My goal is to have my front page properly display the blog.

    Also according to the above link if I make the chnages they discauss some users would not be able to click on “edit comment”.


    Don’t worry about the “edit” link – it will be JUST for you as admin. (Normally, in most of the themes, when logged in as admin, there is an “edit this” link next tot the posts)
    Focus on major things, not details 🙂

    “Normal” install is whatever works for you. It might be totally different for me. Or for the neighbour…

    My goal is to have my front page properly display the blog.
    Then you have 2 options:
    – install WP in the root
    – use the link I gave above

    Thanks moshu. I will give it a try. I would like to volunteer some of my time at somepoint to WP. Do you have a link ?

    I just tried to implement the link and hit one stumbling block.

    The link says to change …
    to the following, using your directory name for the WordPress core files:

    However, my file says

    My question why does my file have 2 slashes.

    Who else is editing your “sweet and short” index file?
    2 slashes is NOT okey.

    I guess I must have changed it at some point, but I have not been in this file for a long time so I am surprised my bloh has been working. I’ll change now to 1 slash. Out of curiousity what does 2 // do ?

    Maybe causing the problems you were posting about 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Directory Problem’ is closed to new replies.