Support » Plugin: jQuery Comment Replies » Directory index forbidden by Options directive

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Doodlebee

    (@doodlebee)

    This is a server setting. It has to do with your host. Basically, if your host has the server to not show directory contents (when there’s no index file available) then you’ll get this error.

    It’s *possible* to fix it, if your host allows you to override the setting with .htaccess. You can open up your .htaccess file and add:

    Options All +Indexes

    However, that will allow people to see what’s in directories if there’s no index.php/.html/.htm file present. If that’s an issue for you, another*possible* solution is to add a blank index.php file to that directory (but it’ll be overwritten in any update I make to the plugin)

    Thread Starter Tony

    (@openuser)

    Thank you!

    Plugin Author Doodlebee

    (@doodlebee)

    Let me know if it worked 🙂

    Thread Starter Tony

    (@openuser)

    I turned on the index.html file in the directory jquery-expandable-comments/css/ and then activate plugin. Answers in comments are no longer visible.

    Plugin Author Doodlebee

    (@doodlebee)

    There’s no index.html file in the plugin. If you added one, I guess that didn’t work (I wasn’t sure if it would). Did you add the suggested line in the .htaccess file?

    Thread Starter Tony

    (@openuser)

    File index.html I added, in order to avoid mistakes “Directory index forbidden by Options directive”.

    Now I’m fulfill .htaccess a way. Is it possible to add .htaccess with parameters Options All +Indexes in a directory jquery-expandable-comments/css/ ?

    Plugin Author Doodlebee

    (@doodlebee)

    Now I’m fulfill .htaccess a way. Is it possible to add .htaccess with parameters Options All +Indexes in a directory jquery-expandable-comments/css/ ?

    I’m not exactly sure what you’re asking here?

    You should be able to open the .htaccess file at the root of your installation, and add that line to it. .htaccess cascades down to the folders below it. If you did that already, and it’s not working, then I’d say you need to contact your host on the issue, because I don’t think there’s anything else you can do on your end. The issue stems from how the server is set up.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Directory index forbidden by Options directive’ is closed to new replies.