Support » Plugin: Download Manager » Direct Access Protection Not Working

  • Resolved fencedeffort


    Please double check the update.

    I was on the same screen shown in the photo below.

    The photo I was working with was named “photo.jpg”

    I applied a restriction and toggled Subscriber.

    The file says it is protected and the toggle says Subscriber.

    I opened a fresh web browser and I am not logged in to the website.

    I pasted the direct link. “/wp-content/uploads/2022/12/photo.jpg”

    I can see the photo. It is not protected.

    Please help! Thank you for the amazing plugin!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Shafaet Alam


    Media access control feature implemented using .htaccess rules, so, it only will work for Apache server. We have tested it

    Thread Starter fencedeffort


    I contacted the web hosting company, and they said that I am using an Apache server.

    I returned to the website 12 hours later.

    I opened a fresh browser and did not log in.

    Within a different browser, I logged in as the Admin and I protected a new file and toggled the option to Subscriber. I then copied the direct link.

    I pasted the direct link into the fresh browser and the file was protected!

    I continued to refresh the screen every 1-min and it remained blocked.

    I returned to the Admin browser and created a new download profile.

    After I clicked “update” within the new download profile and published the page, I returned to the fresh browser that I was not logged into.

    I refreshed the browser once again and the direct link page became accessible with no protection.

    The page with the direct link turned from being blocked to exposing the file after I created a new download profile.

    Please check to see if you can recreate this error. Thank you!

    Thread Starter fencedeffort


    There may have been a problem with the cache on the server side. Thanks for the help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.